Flash drives unreadable

  LinH 19:39 21 Feb 2006

Can anyone help with this problem please?

I recently bought a 1gb flash drive which worked perfectly up until today when it suddenly became unreadable. It comes up in My Computer as a removable drive but it's properties report the file system as RAW with no bytes (used or free space). Double clicking on it brings up the message 'Please insert a disk in drive H' so obviously it is not being recognised. Neither does it show up in the Partition Magic or Diskeeper utilities.

Strangely enough, my 512mb flash drive also failed at the same time. This time the file system is reported as 'unknown' with similar no bytes (used or free space). Everything else the same as above.

Odd one this so would appreciate any comments.

Thanks in advance.

  Inky 13:02 22 Feb 2006

Complete shot in the dark!

With the computer switched off, switch off the main power at the plug then hold in the power switch for 10 seconds.

I had problems with my system booting and recognising the card reader, but this released a build up of static and got everything going again.

  LinH 16:11 22 Feb 2006

Hi Inky,

Thanks for your reply, that's an interesting tip to remember. I tried it but it didn't work, unfortunately. I need to somehow rewrite the MFT/Boot sector software, it's obviously corrupted in some way.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

HomePod review

Streaming : Netflix ou Amazon Prime Video ?