Flash drive will not work on XP PC

  Sue Tait 13:50 11 Apr 2010

I have tried 2 different flash drivces in my XP (SP3) pc.

the system tells me that new hardware has been found but is unable to find the drivers ( which I understand should be within XP anyway)

When I go in to My computer - Disk Management and look at the properties of the device (I renamed it G - it was automatically assigned F but another website gave the advice to change the letter - no effect) - the properties describe it as my HP PSC 2175 - complete with associated drivers! If I try to access the device 'G' it ask for a disk to be inserted.

I tried unplugging the USB from my printer - then the Flash drive wasn't seen at all.

This seems weird and irritating as both drives work on other pcs just not mine! And I certainly don't understand the HP printer association. Can anyone shed any light on this please.

Kind regards
Sue Tait

  james105051 14:40 11 Apr 2010

Perhaps this may be of some help. click here

  Sue Tait 14:58 11 Apr 2010

james105051 - thanks for the post - I had seen this fix on MS and I have just tried it out with no luck.

The thing is - MyComputer actually sees the device - removeable drive 'G'. But if I try to move anything to it it askks for a disk to be inserted and also it cannot see what is already on the drive(s) - I am trying 2 separate flash drives - which i know have something on them - also the attempted fix from Microsoft - came up with 'new hardware found' (this happens all the time too) but again when trying to go through that scenario - it is never table to find the relevant software.

I do not know what makes the flash drives are as they have been branded with company logos

  james105051 15:10 11 Apr 2010

Some drives have a lock on them in the form of a very small tab\switch, could it be this has inadvertently moved an locked the drive.

  Sue Tait 15:29 11 Apr 2010


Can't see anything on the drives - and they have been used on other pcs with no switching off or on of anything - they just work !! - very frustrating.

Thanks for your input though.

  Fruit Bat /\0/\ 17:55 11 Apr 2010

If the camera / pen drive / disk drive is showing up in your Windows' Device Manager under "portable devices" with a yellow "!":

1.) Right-click the yellow "!" and choose "update driver".
2.) When given the option to connect to Windows Update, choose "no, not this time" and click next.
3.) Choose "Install from a specific location (advanced)" and click next.
4.) Choose "Don't search. I will choose the driver to install" and click next.
5.) Click the "Have Disk" button. Browse to C:\Windows\inf and choose the file marked "wpdmtp.inf"

The wpdmtp.inf file might be damaged. It will say the the INF is invalid, go to click here and download a new one and replace the damaged file located in C:\Windows\inf. Relaunch installation, the device is gonna be recognized as a disk. Go to device manager and update the driver. Youre done.

  Sue Tait 09:42 17 Apr 2010

Fruit bat - thank you for that - tried it still doesn't work (sorry for lack of response - completely broke it last weekend by deinstalling the USBs and then couldn't get the system to see anything after that so internet printer everything unavailable!) When I tried the wpdmtp.inf first few attempts when I was browsing through to find the file - it kept defaulting back to the c:\windows\inf whenever I clicked o the next step but eventually it did something which was to think it had installed a floppy (A) drive. This doesn't work either - if you try the flash drive in the USB port it still sees the fact that there is something there but no data and it you try to do anything it asks for a disk to be inserted. I am on XP version 2002 - would an upgrade to a later version help this problem?

  Fruit Bat /\0/\ 09:56 17 Apr 2010

click here try this to uninstall all devices shown as NOT connected also uninstall any shown as mass storage device.

reboot the machine and retry your pen drive windows should find and install.

  Sue Tait 11:22 17 Apr 2010

I have seen something about enabling the upnp in windows and did something in add/remove software in windows components - this has allowed me to see the drives better - the first one is a Chipsbnk - the drive says it is 8mb but I guess it is bigger than that but what I have read suggests that it is difficult to read and it will not format - tried downloading Flash Disk Manager and some Password software for Chipsbnk but nothing works. Also downloaded something called UMPtool for formatting the drive but cannot get that to work either

the second drive is now coming up as a generic USB Flash drive - and I can read this now (so far) and have been able to copy stuff over to it - hoorah!! - so it must be enabling the pnp that was the problem but the Chipsbnk drive is still a mystery - I'll see if there any suggestions for this Chipsbnk thing before resolving this - at least we go a 50% result!

  ronalddonald 12:08 17 Apr 2010

This flash drive is it a memory stick or mobile internet modem

  ronalddonald 12:33 17 Apr 2010

does the drive need to be formatted ?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?