Flash drive not installing

  vin 20:05 13 Jul 2009

Hi there,

Can someone help me. I am having problems with getting flash dives and memory cards to work on my Pc. I am runnig XP home with SP3.
The flash drives and memory cards are recognised when they are inserted but the software fails to install by the instalation wizzard.

The flash drives work fine on other Pcs and the usb and card readers are working fine with other hard drive running same XP.

Is there a currupt instalation file some where?

Please help.

  rawprawn 20:28 13 Jul 2009

Have you tried uninstalling all the USB drivers in Device manager and then rebooting?

  vin 20:42 13 Jul 2009

Thanks for the prompt reply Rawprawn,

I have not tried this as I recently installed a web cam using the same Usb ports and it installed it using the driver which came with the web cam.
The installer does not install any plug and play units.

Will the usb drivers be on the recovery disk that came with the Pc. as I do not have a proper XP disc.

  vin 20:48 13 Jul 2009

I did try to uninstall some drivers in the device manager but they were the drivers for my usb Mouse and keyboard but they now do not work so I am relutant to uninstall any more of the usb drivers.

  Technotiger 20:52 13 Jul 2009

You should uninstall ALL the usb items in Devices, then re-start your computer and the USB Ports will all be re-installed/refreshed.

  rawprawn 21:25 13 Jul 2009

Do it as Technotiger suggests

  lotvic 23:09 13 Jul 2009

I recently had the same problem with uninstalling USB drivers and messed it up by uninstalling keyboard & mouse and had to shut down using the button on tower. I have since found the 'proper' way to do it.
(or you could just try the 'refresh' option instead of uninstalling usb)

To have windows reinstall USB device drivers you will need to uninstall the device in device manager. after a restart windows will reload the required drivers for the drive from its driver cache.

Right click on computer, pick Manage.
Computer management screen will come up, Click on Device Manager on the left, then expand the option for Universal Serial Bus Controllers.
You can right click on the USB root Hub and use uninstall.
This will disable the USB port and all connected devices until the computer preforms a restart.

You can preform this action for all USB root HUB's listed but please note that if your mouse and keyboard are USB devices they will become disabled.
While uninstalling the USB Root Hubs miss out (don't uninstall the Root Hub) that has a USB mouse or USB keyboard.
You can check what device is connected to each listing for USB root Hub by double clicking on each one, which brings up a property window. Under the "Power" table it will display which items if any are associated to that Hub.

Then when complete restart the system.

  vin 17:51 14 Jul 2009

Hello to all,
Thank you for your sujestions. I unistalled all the usbs and then shut the pc down and unpluged at the mains and left it for 5 minutes.

When I restarted the pc it came up with 'new harware found' Universal Serial Bus Controler.( there are 5 of these) but it would not install the drivers as it could not find them.
I inserted the 2 discs I got with the Pc but the drivers were still not found. Now all the usbs have a yellow question mark on them. It also has a unknown devise found.

Please help.

  woodchip 17:59 14 Jul 2009

If your Computer is a Old Computer that used to run 98se or ME then that may be the problem as it's the same with my 98se when I go over 1Gb

  woodchip 18:00 14 Jul 2009

This computer is Dual Booted with XP Home on another Drive, I think its the same on XP on the other drive. they are okay on my new computers

  vin 18:02 14 Jul 2009

This is a 3 year old Medion Pc with XP Home and 1 GB ram installed. No previous operating systems on it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Creative studio Omnibus' brand identity for We Said Enough, a non-profit against sexual misconduct

What to ask Siri on the HomePod

Meilleurs VPN (2018)