Firmware Problem - is my DVD re-writer dead?

  Limpoet 21:21 28 Mar 2005

I have a Freecom Classic Series external DVDRW8B9. I tried to upgrade the firmware today from the manufacturers website. During the update there was an error (not sure what caused it) and now the drive will not do anything. I have uninstalled and re-installed the hardware a number of times and tried to run the Firmware update utility but keep geeting an error message saying "Target NEC ND-2510A is not found correctly".
Does anyone know how I can restore the orignal Firmware or is their a way I can get the new firmware to load.

I have tried the manufacturers website without success.

I am running this on Windows 2000 pro with Intel P4 1.5Ghz & 20Gb HDD. I also have a notebook running XP so maybe I could try a solution on this?

  JonnyTub 21:27 28 Mar 2005

try in safe mode

  Limpoet 21:49 28 Mar 2005

The DVD re-writer is external. Will starting in Safe Mode allow me to do anything that I can't do running Windows in full?

Sorry if I am being a bit dim here.

  JonnyTub 22:04 28 Mar 2005

By starting in safe mode windows will only start the most neccessary drivers it needs, this can help if there's any current conflict not allowing you to flash back to the original firmware.

  Mikè 22:06 28 Mar 2005

I have found click here to be a usefull site for help with firmware matters, there is an NEC forum (Freecom oem's).

  Stuartli 10:21 29 Mar 2005

Updating CD or DVD rewriters' firmware is, at best, a potentially risky exercise and, at worst, a drive fit only for the local refuse collectors.

There has to be a very good reason to do a firmware update.

  TomJerry 11:04 29 Mar 2005

otherwise, try the newest firmware again click here

  Limpoet 12:24 31 Mar 2005

Thanks for all your help everyone. Tried all the suggestions with no success so Freecom are taking the machine back (although I have to pay to return it!) and looks like a replacement will be winging its way. I think in future I will follow your advice Stuartli.

  Chegs ® 13:15 31 Mar 2005

I upgraded the firmware on an old CD-RW,changed its max write speed to 8x and its still working perfectly after 3 years.Upgraded the firmware on my DVD-RW,its now region free,and working well after 2 years.Altered the firmware on a defective DVD-ROM,its still defective. :-)

Altering firmware is a risky business,I usually only attempt it on older hardware(if it knackers the drive,it was going to be replaced anyway)but I have successfully altered the firmware on CD-RW/DVD-RW/SATA Controller/SATA HDD.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Artist Helen Friel on designing paper models for everyone to make

What to expect at Apple's 27 March education event

Idées cadeaux pour geeks et tech addicts