File association problem

  chalkie 11:58 19 Apr 2010

This is a strange problem. (Windows 7 Home Prem)

I recently downloaded and installed the latest iTunes/Quicktime etc.

After this .mp3 files would not open with it nor any quicktime files. After manually doing so the mp3s worked but wht quicktime have an error 46 ativex problem.

The same happened today with a new version of WinZip, when in the program the box to associate zip files is unchecked, when you enable it and press ok it reuens to the unchecked state again.

Manually associating will let them be opened but there are no Right-Click enhancements of any sort.

THe tech support guy here at work (Knows more than the rest of us)!! says a virus has caused it and the only way to rectify is to wipe the disc and start again. Both Norton & Malwarebytes are clear

Any help would be nice. Thanks

  chalkie 12:45 19 Apr 2010

Unfortunately system restore has been disabled by work for some reason known only to them! Wonderful!

  chalkie 10:37 20 Apr 2010

A dissapointing response from a normally excellent forum. Thanks Marg7, I will plod on regardless.

  chalkie 15:28 20 Apr 2010

You presume too much! I am in the fortunate position of having to use mp3s etc as I work in the 'media'.

Thanks very helpful indeed, and what a waste of time!

  rdave13 15:42 20 Apr 2010

If you think some files have been damaged by a virus etc., try running the system file checker. It tries to auto fix in Win 7; click here
If it works then re-enable sys restore.

  Fruit Bat /\0/\ 16:01 20 Apr 2010

Never tried it for windows 7

Step 1: Download subinacl.msi from the link
click here and install it.
Step 2: Download my modified version of reset.cmd from click here and save the file in 'C:\Program Files\Windows Resource Kits\Tools'.
Step 3: Open Command Prompt and type the following without quotes (hit Enter):
'cd c:\program files\windows resource kits\tools'
Step 4: Now type 'reset.cmd' and hit Enter (without quotes)
You will see the Command Line Tool running for some seconds. The issue should have been fixed and Quicktime should run again.

  chalkie 16:45 20 Apr 2010

Thanks for the above sfc said everything was in order.

Fruit Bat on step 2 all I get is a blank page on, any ideas?

  Fruit Bat /\0/\ 17:18 20 Apr 2010

Ok site down

Create a file called reset.cmd with Notepad. Copy the text below into the file reset.cmd and run reset.cmd with administrative rights (it may take a LONG time):

cd /d "%ProgramFiles%\Windows Resource Kits\Tools"
subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
subinacl /subdirectories %windir%*.* /grant=administrators=f /grant=system=f
secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

  chalkie 17:44 20 Apr 2010

OK will give it a try. Thanks, will get back.

  chalkie 20:54 20 Apr 2010

That took some time, (not this long though!). Thanks, at least the the Quicktime part of the problem is solved. Only the association part to go.

Have been told in another forum my tech guy was right, and part of the registry is FUBARed,so will probably hand it over to be done, just got it the way I like it too!

O well nevermind, would love to know how the virus got there, past the 2 defences! Ocupational hazard unfortunately.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

How Pentagram and other design agencies aim to double the number of creative female leaders

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?