"Failed to find a Directx device"

  fpg 18:01 08 Nov 2009

Curious problem this - it came out of the blue. Like many millions I need a daily game of Freecell.
But no more! All I now get is "Failed to find a DirectX device" message.
So I downloaded DirectX from the M S site and tried an install. But it said that it was already installed in the Vista O/S.
As this is a very new PC I do not have a system restore point to go back to.
Any ideas welcome

  GaT7 18:17 08 Nov 2009

Are there any conflicts in Device Manager, especially under 'Display adapters'. If yes, try reinstalling your graphics card drivers. G

  GaT7 18:24 08 Nov 2009

If no joy with the above, install the latest DirectX 9 (idea taken from click here).

Web installer click here


Full download click here


  rdave13 19:00 08 Nov 2009

As Crossbow7. Even though your PC is new you should always have a system restore. Check if running;
Control Panel--System Security--System--advanced system settings--system protections--check if system restore is enabled.
Click on the drive disc and configure tab. Set amount of disc space to about 15% to allow for restore.
It's a fairly big ammount but I think the minimum if you'll ever need it.

  fpg 20:39 08 Nov 2009

Cossbow - Followed first link quick download and installed. No. So did a reboot - still No.
Next full DirectX download 103Mb but still the message blocks Freecell et al.
Device Manager 'unfortunately' reports all working properly. Tried Graphics driver update but I ssem to have the latest.

rdave13 - yes I should have tried further with System Restore. I have now gone back to a Freecell working day - rebooted BUT still no joy.

Advice appreciated I realise that that there could be a dozen causes, the search continues....

  citadel 21:25 08 Nov 2009

if you have the windows disc you can use it to repair.

  fpg 20:07 12 Nov 2009

I had decided to have a break from Freecell et al and do some tidying up on the PC. After uninstalling some programs I found that the error message had stopped appearing and Freecell was working OK.
There must have been a sofware conflict.

But thanks to all for the good advice.

  gigagiggles 02:58 13 Nov 2009

what villainy, depriving users of freecell fun!

you may have to put those uninstalled programs in a lineup. :-)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

HomePod review

Comment regarder les Oscars 2018 ?