extra SATA drive prevents booting

  rogermatthews 17:43 19 Apr 2013

Hi. New build, Gigabyte GA-Z77 D3H mobo, installed Windows 7 on new SSD, no problem. Added new SATA3 hard disk, then one SATA2

disk from old PC, again they worked. But when I try either of two more SATA 2 disks from old PC, Windows won't boot. It tries to

install files, then just asks me to reboot from a proper boot disk; sometimes it tells me NTLDR is missing. Simply unplugging disk

lets it boot OK (I've tried different cables etc)

I have checked BIOS and the first boot device is Windows Boot Manager; changing this to the SSD with the OS doesn't let the PC

boot (even without the extra hard drives). I have even disabled all drives except the SSD but no different, and when I go into the

BIOS again, it has changed the settings back. It seems Windows Boot Manager insists on looking at the new hard drives before the

SSD (that's my guess, anyway!)

It's driving me mad! Any help would be much appreciated. Thanks


  Fruit Bat /\0/\ 18:50 19 Apr 2013

As your new board will have EFI I think you may need to read here

  rdave13 19:11 19 Apr 2013

As Fruit Bat /\0/\ but a bit confused by your posting. When you installed 7 on the SSD then all OK. Then you added older drives with possibly one having another OS installed on it?

Not really familiar with UEFI but I would be inclined to start again just with the SSD and format and install 7 again without the other drives.

The older drives I would format (having backed up all your documents etc), using a caddy before connecting them to the motherboard. Some tips here about MBR and GPT.


  rogermatthews 20:52 19 Apr 2013

Thanks rdave13, FruitBat

rdave, the drives are data storage only, no OS (the remaining drive on my old machine has the OS, WinXP). Presumably if a drive I was transferring did have an OS, windows would recognise it and use it.

I will read your links, but at the moment clicking on them does not open the link - what's that all about? Seems like others have had this problem. This is doing my head in. (It's IE10 by the way)

Could you perhaps post the links as full paths which I can copy and paste? Or if you know the solution to my new problem?

Very grateful, thanks


  Fruit Bat /\0/\ 20:57 19 Apr 2013
  rogermatthews 21:21 19 Apr 2013

thanks, Fruitbat, a guick glance suggests it might be promising, though why I now have to learn and mess about with bootcfg files is beyond me. Almost every post on fitting sata drives says how simple it all is! WHy on earth is there a boot priority option in the BIOS if it doesn't work!

i'll look into it tomorrow, right now I've got to sort out the IE non-responsive hyperlinks problem. Two days messing around with this and I've found out more about what hardware, software and parts of Win7 DON'T work that than actually being able to get on with what I want to do.



  rdave13 22:08 19 Apr 2013

rogermatthews , UEFI (BIOS) replacement will be the final nail in the coffin of adaptable Desktops I sadly think. Also of Windows.

There's already been one strange post here about hacking UEFI albeit from USA.. UEFI can access the internet in it is own right. So it is a mini OS to take care of a secure boot?

Send the mobo back and replace with a mobo with the old BIOS.

  rogermatthews 22:26 19 Apr 2013

Hi rdave13. I can't pretend I understand the full implications of what you say, but if it's a step to bringing Microsoft down, I wholeheartedly support it!

The mobo is a Gigabyte GAz77 d3h, a widely sold and proven board, and plenty of reviews (eg on Amazon) show people are happy with it. Also, I've used an OEM copy of Windows so it's tied to it. I could argue with the supplier but I really don't want the hassle. Somehow, this thing must be able to work.

It's more the hassle with Windows that's causing me grief right now. I've just uninstalled IE10 and found IE9 is running. Trouble is, there appear to be two versions, one denoted as 64bit. They both point to the same file location though! One version allows hyperlinks to open, but hte Norton toolbar (identity safe) is missing. The reverse for the other. So neither does what I want.

I'm going to bed - right now I feel like binning the whole lot!

Cheers and thanks


  rdave13 22:38 19 Apr 2013

You have a new built and have Norton installed.

Have a word with Norton.

Good luck.

  lotvic 23:04 19 Apr 2013

"I've just uninstalled IE10 and found IE9 is running. Trouble is, there appear to be two versions, one denoted as 64bit."

That is normal.

Use the one that is not denoted as 64bit. It is the 32bit version and is more compatible with websites. There are known issues with the 64bit IE and Microsoft recommend using the 32bit IE on pcs running W7 64bit.

re Norton, try this solution http://community.norton.com/t5/Norton-Internet-Security-Norton/No-Norton-Toolbar-in-IE9/td-p/419024 scrolldown to SBM'S instructions.

  rdave13 23:21 19 Apr 2013

lotvic , nice find.

rogermatthews , but if it's a step to bringing Microsoft down, I wholeheartedly support it!


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Majority of illustrators don’t earn enough to live from, new survey shows

iPhone X problems

Word gratuit : comment télécharger le logiciel de Microsoft ?