External HDrive Lost ALL Data. Can it be Recovered?

  Legslip 20:38 28 Jun 2013

I have an Iomega Xtl drive and when I plug it in a window opens and ask if I want to format it. I hit NO and then another instruction appears that states "E is not accessible. The parameter is incorrect".

If I go into properties it states the disk size is 0gb and that there is 0 data on it.

It does/did have important data on it. Can anyone advise what has happened and if it would be able to recover the important data?

  john bunyan 20:45 28 Jun 2013

If your PC can "see" the drive, you could try Recuva See:


  rdave13 20:46 28 Jun 2013

Which Windows OS are you using? If 7 or Vista try connecting to an XP machine. See if you can get the data off it. Could be an incorrect disconnection or shutdown when drive using cashe. Win 7 vulnerable to this but XP might mighr read it correctly.

  Legslip 21:41 28 Jun 2013

Thanks Guys. Tried Recuva but did not find files and also in XP but get the same results as on my Win 7 PC.

Someone mentioned to me to try Ubuntu. Anyone know anything about it and if it might work?

  Legslip 21:42 28 Jun 2013

PS In properties in XP it states the file format is RAW!

  Fruit Bat /\0/\ 21:59 28 Jun 2013
  Legslip 22:09 28 Jun 2013

Hang on...... Recuva seems to have kicked in! Fingers crossed, will advise.

  Legslip 15:29 29 Jun 2013

Thanks "The Poet". Recuva worked a treat. Thanks for the other suggestion Fruit Bat.

  john bunyan 20:14 29 Jun 2013


Thanks for feedback. Glad it worked!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)