External HDD not recognised for what it is

  Graphicool1 22:47 07 Dec 2013

Windows 7 32bit

I have a Western Digital 1TB external HDD. It's always plugged in, however, this evening I was having some (on going) problems with my PC. So to protect the contents of the external HDD I decided it was safer to disconnect it from the PC. But when I plugged it in again, it didn't recognise it and loaded drivers for it.

The problem is it's now calling it an 'Intitio Default Controller' and as such doesn't show it in 'My Computer'. I can only find it in 'Devices and Printers'. When I click on it, it doesn't open or do anything?

I tried to get in touch with WD but they just gave me the run around, by showing my FAQ's. I have loads of stuff on there that I can't afford to lose.

  Graphicool1 15:28 08 Dec 2013

Hi guys thanx for your inputs, however, niether of your suggestions applied. I tried plugging into different ports, but the out come was the same. So I switched off the PC and unplugged the HDD. I rebooted the PC, then switched it off again and plugged the HDD back in and rebooted. Bingo, it was recognised.

Phew, that was a scary moment. I keep meaning to do more backups of my data, but I'm sure you know what good intentions are like...perhaps tomorrow. But we all know tomorrow rarely ever comes for fixes. Tomorrows are full of regrets for the fixes we never got around to do.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Qu’est-ce qu’Amazon Prime ?