External Hard Drive Files Not Accesable

  PaulWyatt 21:20 21 Aug 2014

I have an external hard drive that has suddenly become unaccesable in "My Computer" when I click on the drive I either get a message that the drive needs to be formatted or that the parameters are incorrect - the 1tb drive is over half full with photos and videos.

The drive itself appears to spin ok and when I run the "chkdsk" prompt through cmd all the drive details show including the number of files and folders and says that there is no error. I just cannot seem to be able to access the files.

Please help as the contents of the drive are of great sentimental importance.

  lotvic 22:02 21 Aug 2014

If you can see the directories in CMD window, have you tried moving/copying the files through CMD window?

Or have you tried booting with a Linux cd and then copying the files.

  lotvic 22:12 21 Aug 2014

Guide: Use Ubuntu Live CD to Backup Files ClickHere

  PaulWyatt 22:16 21 Aug 2014

Thanks for your reply, the CMD window just shows the drive stats (eg 25 files in 10 folders) rather than the actual files or directories so nothing I can copy from here.

  lotvic 22:22 21 Aug 2014

One thing to try before using a Linux cd, switch pc off, plug in external hard drive, switch it on then boot up the pc. This sometimes 'fixes' it and files are recognised in Windows long enough to copy them off.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?