External hard drive enclosure not working in Win 7

  willy boy 17:18 12 Jan 2010

I have installed an 80 gig hard drive in an enclosure that was in a XP 32 bit Dell. The drive just contains data (it was a slave). I have reset the jumpers to "master" as instructed. The drive seems to fire up and is recognised by Win 7 64 bit on my new pc as USB to IDE bridge, USB mass storage device but I cannot access it either through explorer or indeed trying to search for files. Could this be related to the drive being NTFS formatted for the 32 bit XP? I would appreciate any help, I have tried windows support but not had any real joy.

  james105051 17:57 12 Jan 2010

Has the drive been allocated a drive letter. Right click on "My Computer" select "Manage" select "Disk Management" and in the right hand pane see if the disk has a drive letter, if not right click the drive and select "change drive letter" and select a letter.

  rdave13 18:12 12 Jan 2010

It should be a 'plug & play' setup in a caddy. Connect the usb then power up, don't connect with power 'on'

  willy boy 18:23 12 Jan 2010

Hi James, many thanks for you swift reponse. I have followed your steps, the drive does not have a drive letter, just disk 5, unknown, not initialized underneath in right hand pane, if I right click I get initialize disk, offline, properties, help. If I try to initialize I get 2 choices mbr or gpt, each one says the device is not ready in virtual disk manager and nothing further happens. there is no option to change the drive letter. Thanks for your help, I guess I will keep fiddling regards ernie

  willy boy 18:29 12 Jan 2010

Hi rdave13 I have also followed your directions for plug&play. I get the usual message your device is installed and ready for use but it still appears as noted above in my reply to james105051 and is not accesssible from anywhere. Thanks to you also

  rdave13 18:51 12 Jan 2010

Try 'cable select'.

  woodchip 18:52 12 Jan 2010

mbr needs doing but you may lose whats on it, partition software may get the drive back such as testdisk

click here click on testdisk on the left put this on a floppy or usb stick to run from boot

  rdave13 18:54 12 Jan 2010

I've a sata 1 and an ide HDD (old one) in two different Allcam enclosures and both work well through the 'plug and play' setup. Never even thought about the jumpers.

  woodchip 18:55 12 Jan 2010

ps as its external it should find and repair the drive partition mbr from within windows by double click on testdisk.exe

  willy boy 14:23 13 Jan 2010

Hi all, many thanks for all the very useful suggestions. I tried the drive in a Vista 32 bit laptop with the same results as in the desktop. Having almost given up I tried playing with the jumpers after dismounting the drive and your suggestion, rdave13, of cable select worked and the drive fired up. For information the drive is a western digital, I do not know if this is relevant but it may help others who might run into the same problems. the enclosure was Sumvision by the way and it was easy to install the drive. Thanks again to all of you who responded.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?