external hard drive device drivers problem

  NoBob 14:30 10 Jul 2005
Locked

Hi,

Am getting frustrated now. And am not sure if this should go in the hardware branch or the software branch. I'll move the thread if necessary.

I bought a Seagate 160 Gb (usb 2.0 only) external hard in late April. It's plugged into an IBM Thinkpad T41/Win XP Pro SP2.

It's worked fine (mostly) up til now, running at usb 2.0 speeds. The problem is that transfer rates have dropped to
USB 1 speeds and no matter how many times I uninstall the device drivers (MY Computer>Properties>Hardware>Device
Manager) I can't get it back to USB 2.0. It's happened before but uninstalling the drivers has fixed it.

The Seagate support online disk checker just says that the disc is fine. It doesn't says anything about usb transfer rates.

After uninstalling the drivers (in both safe and normal mode) and then plugging in the Seagate again, Windows displays popups:
Seagate>ST316002 3A>disk drive>USB Mass Storage Device and then "This USB device driver can perform faster...plugged
into a USB 2.0 port". It's already plugged into a USB 2.0 port (in Device Manager it shows that the host controller is 'enhanced')
but windows still tells me to plug it into one of six usb ports that are USB 2.0. The USB laptop slots and the external High-Speed
USB Hub I use are both usb 2.0!

I get the same problem (Windows' recognition of the hardware device name but only USB 1 speed) when I plug my 40Gb
Tripper (USB 2.0) into the external external High-Speed USB Hub.

I work on large TIFF files so USB 2.0 is a must.

In Bios (checked when booting up) there is only the option to enable or disable USB. Not much help there.

Should I reinstall SP2?

Thanks,
NoBob.

  howard60 16:02 10 Jul 2005

it sounds as if your usb root hub has become corrupted. Get your mobo cd and reload the usb hub driver.

  woodchip 16:03 10 Jul 2005

You do not need drivers for XP drive, only for WinME or Win98

  woodchip 16:09 10 Jul 2005

This sounds like a WinXP USB2 problem where there as been patches for USB also if you have a Via chipset you would need the 4 in 1 Drivers this may help and worth a look. check your board before you do anything click here

  NoBob 16:54 10 Jul 2005

Thanks everyone.

...but Howard, what's a mobo cd? Thinkpads don't come with any cds, nor the Seagate. All backup info is on a 5gig partition that's pre-installed.

And after posting my first message I downloaded USB Info and ran it. It shows that all the USB 2.0 devices I have are run by the 1.1 controllers. Even when I uninstalled all the drivers except for the 'enhanced controller' and plugged in the Seagate, Windows still went ahead and installed the 1.1 drivers and hooked the Seagate up to one of those.

Totally stuck now.

NoBob.

  NoBob 19:38 10 Jul 2005

Passing on the good news...

Fixed the problem by downloading the IBM Software Installer and updating the Bios and other drivers.

Checked the USB set up using USB Info tool, which shows that everything now works off the USB 2.0 controller.

NoBob

  NoBob 21:44 10 Jul 2005

I unplugged the Seagate (using the eject tool) and the external USB hub to take it downstairs and when I plugged everything in again...it's all back to usb 1.1 !!!!!!!!!! I don't believe it!!

I also uninstalled the secondary IDE, but that didn't work.

NoBob

  Adil 20:49 22 Feb 2006

I had same problem; My USB hard drive was not working at 2.0 speed but 1.1 Windows constantly nagged me about the problem.
After checking with intel site, i managed to solve my problem.
Intel advises to go to BIOS and check if USB 2.0 is enabaled. In my my case it was not. I simply enabled it and am enjoying the fast downloads with card readers EOS 20D.
Thanks for the good discussion.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Inside the iMac Pro - Apple's most powerful Mac yet

iMac Pro release date, UK price & specs

Comment nettoyer Windows et optimiser son PC gratuitement ?