External drive not now visible on other PC

  compumac 21:59 24 Jun 2010

I have two PC’s using XP Home and networked through a BT Home hub. Both of the PC’s have external hard drives attached and each of those external drives have been visible to the other via Windows Explorer. I have just installed a new hard drive on PC1 and restored an image created the day before. Those external drives can still be seen from their own Windows Explorer.
I now find that whereas I can see the other PC in Windows Explorer and can access the folders within the internal drive, I cannot now see the its external drive. What do I need to do to access those external drives?

  mgmcc 21:51 25 Jun 2010

Try "unsharing" the external drive (although it may already have lost its shared attribute), reboot the PC and then set the external drive as "shared" again.

  compumac 22:16 25 Jun 2010

Thanks, but I have already done that. Nevertheless your help is appreciated. Any other thoughts?

  mgmcc 08:34 26 Jun 2010

Can you access the drive by typing the path to it directly into the address bar in "My Network Places"?


  compumac 08:51 26 Jun 2010

Have not tried that, but when you say the address bar in "My Network Places", I am not aware of an address bar being displayed. I am on XP Home.

  compumac 09:14 26 Jun 2010

Have found that address bar was not shown because it had not been selected to show. (slap wrist/s). However inserting the drives address produced the same non result.

  mgmcc 11:11 26 Jun 2010

In the computer to which the external drive is connected, does it show in "My Computer" as shared, i.e. does it have the hand beneath its icon?

  compumac 11:31 26 Jun 2010

Yes on both accounts

  mgmcc 15:37 26 Jun 2010

It does seem very weird. Try sharing a folder in the external drive, instead of the root of the drive, and see if that can be found and accessed over the network.

  compumac 15:48 26 Jun 2010

You are not watching Paraguay v Korea then? Just tried your suggestion and the answer is no. "Not enough server storage is available" is the dialogue box that comes up, (which has been the response each time).

  mgmcc 17:41 26 Jun 2010

>>> "Not enough server storage is available"

Aha! Now that is very significant. Have a read of this:


Not enough server storage is available to process this command.

Not enough memory to complete transaction. Close some applications and retry.

These error messages can indicate an incorrect IRPStackSize on the remote computer (the one you are trying to access over the network). In the remote computer, open the event log and check for event ID 2011. If this is present, it may indicate this particular issue. To repair it, you need to set the IRPStackSize parameter in the registry back to its default value of 15.


Check for the presence of a value named IRPStackSize. If it doesn't exist, create it as type DWORD and, with base set to decimal, enter the value 15. Exit from the registry and reboot the computer.

Some AntiVirus programs are guilty of altering this setting and causing the problem. Also have a look at this Microsoft Knowledge Base article which applies to XP too:

Antivirus Software May Cause Event ID 2011 (Q177078)
click here


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Artist Helen Friel on designing paper models for everyone to make

What to expect at Apple's 27 March education event

Idées cadeaux pour geeks et tech addicts