External drive ceases to be recognised.

  dogbreath1 14:20 18 Feb 2005

I've been using an external HDD in conjuction with Acronis True Image to keep disc images. Normally the external drive is recognised by My Computer as Drive 'H'. The drive has ceased to be recognised. I'm using XP Home SP2. Help please.

  Yoda Knight 14:39 18 Feb 2005

I take it u've checked all the cables... does it sound like there is power in the externl drive (a humming noise / slight vibration) ?

  Fruit Bat /\0/\ 14:43 18 Feb 2005

Any yellow marks on the USB connections in device manager?

Try uninstalling and reinstalling the USB root hubs.

  dogbreath1 14:50 18 Feb 2005

Yoda Knight. Cables checked. Power on.
Fruit Bat /\0/\. Yeah. There's a yellow mark against USB Mass Storage Device.

  dogbreath1 15:00 18 Feb 2005

In Device Manager, error reads 'This Device Cannot Start (Code 10)'

  Fruit Bat /\0/\ 16:24 18 Feb 2005

This device is either not present, not working properly, or does not have all the drivers installed. (Code 10)

To resolve this error code, make sure the device is connected to the computer correctly. For example, make sure all cables are plugged in fully and that all adapter cards are properly seated, and update the device driver. It may be possible to remove the device and redetect it using the Add New Hardware wizard.

  dogbreath1 18:31 18 Feb 2005

Thanks for that Fruit Bat / \0/ \. I unplugged the usb plug and tried another usb socket. And it worked o.k.. Looking in Device Manager, the error had disappeared and I've been able to save an incremental image to the external drive. Also I checked the usb socket which used to serve the external drive by inserting a pen drive, which was also recognised. Haven't a clue what went wrong but it all seems o.k. now. Again many thanks for your help.

  dogbreath1 17:10 19 Feb 2005

Booted up today. Lacie external HDD again not recognised. However, Mass Storage Device 'H' displayed in My Computer. Properties shows the latter device to be empty. Device Manager doesn't show up errors in USB root hub. Tried rebooting twice but system wouldn't fire up with the Lacie connected (similar to a non-system disc error I suppose). In each case, as soon as Lacie disconnected, XP booted as it should. With the Lacie still disconnected, the ghost Mass Storage Device 'H' still displayed in My Computer. Any help would be much appreciated.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

How Sketch and InVision have revolutionised our design workflow

The best tech gifts for Christmas 2017

Les meilleurs jeux de société (2017)