explorer.exe has caused an error

  jayne_uk 20:02 03 Oct 2003
Locked

please help. I am continuously getting 'explorer.exe has caused an error and will be restarted.' messages on my pc. Then when I click ok the desktop disappears and I have to reboot. I am running Windows 2000 and have recently installed Service Pack 4. This only occurs when I am logged in on my account and not any other accounts. I can't uninstall the service pack as it makes changes to the registry that I cant repair without a backup of the registry. I dont know what to do - any ideas?

  VoG II 20:32 03 Oct 2003

In view of the deafening silence...

A search on the MS Knowledgebase shows many, many causes of explorer.exe errors in W2K. I just wonder if click here might be connected in some way?

  TOPCAT® 20:51 03 Oct 2003

.. here's some items from Microsoft's Knowledge Base to check. As VoG says, there are many to view but I can find only one reference to Service Pack 4 which is at the second link - scroll halfway down page. TC.

click here


click here=

  jayne_uk 22:58 03 Oct 2003

Ive looked on the links u gave me and many message boards on the net but it's still not solved the problem. Is there any way of just re-installing explorer.exe from the Win 2000 disk? or is it possible to re-install windows without formatting the disk and losin all my stuff?

  VoG II 23:04 03 Oct 2003

I don't know if this will work in W2K but try Start, Run and type (or paste)

SFC /SCANNOW

and click the OK button.

  jayne_uk 23:08 03 Oct 2003

I tried to run that before and it prompts u to put the win 2k installation disk in & i did and it wouldn't work.

I've also installed ad-aware and checked for spyware that may have caused the problem but no joy there eitha.

  VoG II 23:12 03 Oct 2003

"I tried to run that before and it prompts u to put the win 2k installation disk in & i did and it wouldn't work. "

What happens, exactly please?

  jayne_uk 23:17 03 Oct 2003

I typed in SFC /SCANNOW and it loads and asks for the win 2k disk. So i put it in and pressed 'Retry' and it started to work but then it kept prompting me for the disk again and again. I kept pressing retry till it got to the end but then a message came up saying I must have used the wrong installation disk because the files were different - or something along those lines. (i know it dusnt make much sense).

  VoG II 23:36 03 Oct 2003

Sorry this is all I can find click here


If you do this, you will then have to install all the cservice packs. However, it may well work.

  jayne_uk 23:37 03 Oct 2003

I also downloaded 3 of the Windows 2000 Hotfixes at the same time I downloaded SP4. Could these b 2 blame? They are critical security updates:

Windows 2000 Hotfix KB823559
KB824105
KB824146

Jus a thought....

  jayne_uk 23:45 03 Oct 2003

Well, im just gonna try re-installing Win2k and then if that doesnt work it looks like il have to format it & start again.

Thanks for all your help.
Jayne

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Turn a photo into 16-bit pixel art

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?