Expensive Doorstop !

  dregn 06:09 21 Jun 2004

My PC is self built and has been running flawlessly for six months.
The mobo is the Abit IC7-G with a P4 2.6C CPU and running Win XP Pro.
Suddenly the OS starts hanging, refuses to shutdown and is generally unstable.

Yesterday it booted but did not recognise the HDDs.
I have a 40GB IBM drive which is the master and has one partition for the OS and a second partition for apps.
The second HDD is a WD 80GB unit which I use for data storage.
I went into the BIOS and this is not detecting the drives.
The boot order had changed so I returned it to safe settings.

The F10 key ( save changes and exit ) has no effect and every time I reboot and access the BIOS, settings have changed.
Sometimes the IDE drives are seen, sometimes not.

The last time I managed to run Windows I ran a virus check without a problem being reported.

The problem would appear to lie within the BIOS and I am flummoxed.

I am tempted to wipe the CMOS ( and remove the battery for a while ) and see if that does the trick.

BeforeI do this I should be very grateful for any ideas and advice.

I am fortunate in having a laptop for internet access.


  €dstowe 08:09 21 Jun 2004

You say you removed the battery for a while, have you tried replacing it?

It can happen that motherboard batteries fail prematurely and if the CMOS reset jumper is left in the reset position, this will happen even quicker. Would be worthwhile checking.


  dregn 09:09 21 Jun 2004


Thanks for that.

I have not yet cleared CMOS or removed the battery.

I will be doing so this this morning and will report.

I suppose I might replace the battery as a last resort, but the board is only a year old at the most.

Thank you again.

  billyliv 09:28 21 Jun 2004

Hi, I would try the repair option first before opening the case. Cheers, Bill

  Gongoozler 09:42 21 Jun 2004

If you're having problems with the BIOS, then your problem doesn't lie in Windows. Make a note of the CMOS settings and get a new battery. That's the most likely cause. If that doesn't help then you might even have a corrupted BIOS, although that usually results in a checksum error.

  STARIE 10:22 21 Jun 2004

This maybe an obvious question but have you check the cables that connect to the HDD. I've had a similar problem and it turned out that on of the cables had moved 2-3mm and was therefore not properly connected. I pushed the cables on again and started the machine back up and everything worked fine. Not sure why it happened but suspect it is related to how much I move my pc about.

  dregn 12:53 21 Jun 2004

Thanks everyone for your advice and tips.

Earlier today I removed the battery and reset CMOS.

Everything is back to normal - much to my relief.

I will replace the battery ( CR2032 ) and recheck all connections.

Since the motherboard is a year old at most I am surprised that the battery is suspect.

I suppose there could be an inherent problem with the motherboard ( Abit IC7-G ) but I will keep my fingers crossed.

Many thanks to you all.

  Valvegrid 13:06 21 Jun 2004

Although the motherboard is year old, its difficult to tell how old the battery was before it was fitted into the board.

  €dstowe 13:11 21 Jun 2004

Those batteries can be very unreliable. Some seem to go forever, others die in a very short time.

It has also been known for old batteries to be sold as new - even in apparently sealed packs which have been re-glued after an old battery has been put in.


  dregn 10:14 22 Jun 2004

I learn something new every day !

  Stuartli 11:44 22 Jun 2004

Never had a CMOS battery fail/end its useful life over many years of sitting in front of my various systems. Current one is more than five years old.

No doubt I'll shortly regret this posting....

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

Iconic New York graphic designer Milton Glaser on his uplifting new subway posters

New iMac Pro release date, UK price & specs rumours

Comment suivre le parcours du père Noël ?