EXE files no longer run - XP Pro

  tunneller2001 18:53 04 Jan 2005

XP Pro with SP1 and all updates APART from SP2. On 1 Jan 05 I booted up the PC and when the adware prog started it informed me that "something" was trying to change protected variables?" (can't remember exactly). I said OK to the first 3 warnings, but eventually there must have been about 30 and I said NO to the rest. Now my exe files are not associated correctly and I can't run any programmes normally. So, REGEDIT etc does absolutely nothing when I try and run it from Start > Run, and any installed programmes ask "what program is associated with this - etc".
I have Kaspersky firewall and anti-virus s/w all completely up-to-date. A recent scan found nothing amiss.
I can run individual programmes by Tools>Folder Options> and adding a new exe pointing to the specific programme. No way to continue, but I can only see that reloading XP will cure the problem.

Any ideas please?

  tunneller2001 18:56 04 Jan 2005

I have tried system restore ad whilst it appears to work OK, the exe file situation is exactly the same. Daft thing is that I have registry backups on System Mechanic but it wouln't let me run it!

  anon1 19:12 04 Jan 2005

Have you tried looking at the adaware log files to try and trace what exactly happened? Have you tried reinstating the file associations manually? Have you also tried a previous date to system restore or just the one attempt? How much memory are you using? Was all ok before these warnings?

  tunneller2001 20:36 04 Jan 2005

Everything was fine pre 1 Jan 05. I have tried 3 different restores, some going back 2 months, but whilst I say they appear to work, I am not sure that they actually revert to the date that I select. May be a red herring.
I can't find any logs that say what was happening when the problem first started.
What I need to do, but can't is change the registry entry for exe as follows:
Click Start, Run and type Command
Type the following and then press Enter after typing each one:

copy regedit.exe regedit.com
start regedit.com [or regedit.com]

Navigate to and select the following key:

Double-click the (Default) value in the right pane.
Delete the current value data, and then type: "%1" %* [with quotes]
(ie., quote-percent-one-quote-space-percent-asterisk.)

Exit the Registry Editor and restart Windows.
1. Start Registry Editor (Regedt32.exe), and select the following key:
HKEY_CLASSES_ROOT on Local Machine
2. From the Edit menu, click Add Key.
3. In the Key Name box, type .exe and then click OK.
4. Select the new .exe key.
5. From the Edit menu, click Add Value.
6. In the Value Name box, type Content Type. Select REG_SZ for Data Type, and then click OK.
7. In the String box, type application/x-msdownload and then click OK.
8. From the Edit menu, click Add Value.
9. Leave the Value Name box blank. Select REG_SZ for Data Type, and then click OK.
10. In the String box, type exefile and then click OK.
11. Exit Registry Editor.

  THE TERMINATOR 20:54 04 Jan 2005

Have you tried click here ....TT

  tunneller2001 19:23 14 Jan 2005

I eventually managed to use a program called Registry Workshop to recover the registry from a backup (couldn't use regedit). I then had to re-associate exe and lnk files which is probably what screwed it in the first place.

Thanks for your advice - I appreciate it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

ManvsMachine and other artists put Apple's iMac Pro to the test using powerful rendering tools

What to expect at Apple's 27 March education event

Comment filmer l’écran d’un iPhone ?