Ethernet switch not working for 2 devices together

  bill_uyen 12:29 11 Jun 2017

Modem > router > switch > desktop + laptop

only the first device i turn on receives ethernet connection while the other device receives no valid ip configuration. could use some help its killing me inside.

Ive tried:

uninstalling/installing/updating/scanning for new drivers

disabling wifi

using DHCP

using static


any advice would be much appreciated!

  Secret-Squirrel 15:41 11 Jun 2017

A couple of questions for you:

1) Most routers have at least four Ethernet ports so what's your reason for using a switch?

2) Has this configuration ever worked?

  bill_uyen 22:45 11 Jun 2017

So the router is upstairs in the electrical room and has ethernet cables plugged into its ports that lead to specific rooms in the house. So I'm hooking a cable from the wall to a switch in my room to supply internet to both of my devices

I'm actually a little unsure if it has ever worked or if I was just on wifi the whole time because the laptop is my gfs and the desktop is mine. I had only noticed the issue when I was on the laptop the other day. When I was younger I could have sworn I had an Xbox and desktop hooked up through a gigabit switch the same way however...

  wee eddie 00:27 12 Jun 2017

Switch /Splitter - which?

  bill_uyen 02:29 12 Jun 2017

Dlink GO-SW-5E switch

click here

  Secret-Squirrel 08:56 12 Jun 2017

Thanks for the info Bill.

Firstly you need to make sure that the switch is receiving power and its corresponding LEDs are illuminated.

Restarting the switch by disconnecting its power cable for a while then reconnecting it may kick-start it into working. It may also help if you reboot the router in the same way.

You could also try connecting the cables to different ports on the switch - they're auto-sensing so it doesn't matter what's plugged in to what port.

A good test would be to connect the switch directly to different ports on the back of the router but that's likely to be too much faff considering the placement of the router and that you have a desktop PC.

Let me know how you get on please.

  bill_uyen 09:35 12 Jun 2017

ive done all the classic "turn off router wait 30 seconds" stuff repeatedly and i have actually gone out and purchased a completely new switch just yesterday to see if that was the issue. Same problem as the old one unfortunately...

I thought it might be the cat5 cables even but since both devices are capable of receiving an ethernet signal independent of each other i am assuming that the cables are a non-issue as well.

When i go ipconfig /all im sitting on 168.254.x.x.(preferred) which doesnt seem right...

ive tried many of the basic trouble shooting stuff and feel as though the switch isnt assigning one of the devices a new ip or something even when im on DHCP though im not sure how switches work entirely.

  alanrwood 09:42 12 Jun 2017

Yes it does not seem right. Most internal ip addresses start with 192.168.X.X Are you set to obtain IP automatically on both devices and checked they are not both set to fixed ip which are the same.

  bill_uyen 09:45 12 Jun 2017

most definitely set to obtain IP automatically on both devices. the first device i turn on receives the Ethernet connection and 192.168.x.x IP, the second device gets the 168.254.x.x. Does not matter which device i turn on first, it just always happens this way

  bill_uyen 09:59 12 Jun 2017

is there a way i can reset anything that was done to the router settings back to default safely?

  bill_uyen 10:46 12 Jun 2017

Gave the router a factory reset and both devices are now working off the switch! thank goodness, now to change the passwords and everything back to normal before everyone wonders why their wifi isnt working.

Thanks everyone for helping, id actually still like to continue figuring out what was actually wrong, though with the problem fixed that probably isnt possible anymore.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Pokémon Sword and Shield preview

Best Office Chairs for the Studio and Home

macOS Catalina Preview: First look at the new Mac update

Que faire si votre iPad ne se charge pas ?