Error Message on Shutdown

  johndrew 12:10 19 Jul 2008

System is XP Pro SP3 version 2002.

Having just done some updates and my PC has started giving an error message at shutdown/restart. The message flashes quite quickly and is difficult to read, but appears to be an `Application` that failed to start; this message is followed by another that tells me the `DLL failed because Windows is shutting down`. they are associated with the the usual warning tone.

I have looked at the Event Viewer and can find two entries that appear to coincide time wise:
In the Application section there is a report of an `Application error (100) event 1000` followed by `Faulting application, version, faulting module unknown, version, fault address 0X00000000`
In the System section there is a report of a `Service Control Manager Error event ID 7001` the description script accompanying this refers to the `Windows Media player Network Sharing Service` depending on Universal Plug and Play Device Host service failing to start.

Whether these two reports are related I`m uncertain as there is nothing to link them in the Event Viewer or the Error windows (that I can see).

I have checked Device Manager for any error reports and all appears normal. I have tried MS help but there is nothing there that appears of value. The PC appears to function normally in all other respects.

Can anyone make any suggestions as to curative actions? I have scanned using Registry Mechanic and Advanced Windows Care but they flag up nothing unusual.

Thanks in anticipation.

  johndrew 12:44 19 Jul 2008

I should also have said that I have run sfc /scannow to ensure the files are OK. Also the TeaTimer in Spybot S&D has started running for a full two minutes at boot - I have disabled this.

  Ditch999 14:41 19 Jul 2008

Sounds like its WMP and its Network service for acting as a media server. Do you stream media around the house?
To disable it go to Tools>Options>Library>Configure Sharing> remove tick from "share my media to" and click OK

  johndrew 15:44 19 Jul 2008

Thanks for coming back.

I have just logged onto the net again after spending pretty much all day fighting this snag; the pleasurable bit is that I`ve nailed it - or at least think I have.

I run a2AntiDialer which contains something called AdGuard. This had apparently become corrupt/damaged somehow and was failing to load. As a result it was not until shutdown that it decided to tell me it was not functioning. To recover it I had to uninstall, reinstall, update and reload the dialers that are allowed and set the parameters for anything that asks for access.

With luck all will now function correctly. Where the messages in the Event Viewer originated I`ve no idea, but for WMP I shall look at taking your advice anyway as it is only used as a free standing player (occasionally) on the PC.

Thanks again. If it all proves to be wrong I shall be back!!

  johndrew 15:47 19 Jul 2008

"share my media to"

Wasn`t ticked.

  Ditch999 15:53 19 Jul 2008

If you still get the WMP error try looking in services.msc to see that Universal Plug and Play is set to Automatic and is Running as is Windows Media Player Network Sharing Services and HTTP SSL.

  johndrew 18:29 19 Jul 2008

It was `Disabled` so I set it to `Automatic`.

As for the original problem, It returned when I reinstalled the antidialer so I have decided it isn`t really important, as I use broadband mostly, and have removed it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

18 Best Adult Colouring In Books 2018

HomePod review

Les meilleures séries Netflix (2018)