epson stylus sx435w great printer but now stopped

  lindseyw 13:10 19 Nov 2014

Can anyone help me. I have the above printer just stopped working, its communicating through a lead as wifi iffy. Plenty of ink, paper, nozzles and heads cleaned so I can see the mac and the printer are talking it just won't print a simple word doc (or anything for that matter) any advice?

  Nontek 14:11 19 Nov 2014

Make sure the printer is designated DEFAULT printer, then re-start pc and try again.

  AJG7 15:01 13 Dec 2014

I too have SX435W problems. Randomly the print command doesn't work. I'v traced it to a breakdown in the communication of ink levels between printer and PC. Ink levels on printer are fine but checking levels by examining "Devices and Printers" shows no ink - hence no print command. I've re-installed 3 times, shut down and restarted etc. When ink levels on the computer are shown as OK the printer works fine. Eventually something kick starts the ink level monitor and it's fine again. Printer WiFi check is fine so I'm thinking it's a software bug. Epson support weren't much help talking about firewalls and anti-virus stuff etc but didn't listen to the fact that it's random. Sometimes lasts for a day before it corrects. I'm at a loss how to cure. Realise this doesn't solve your problem but it might help to isolate it if the problem is the same as mine.

  AJG7 13:45 02 Feb 2015

I think I've solved my SX435W not printing problem Try this. Go into the Firewall (via Control Panel - security) and check that BOTH Epson Event Manager programs are allowed. 1 is "Private" and 1 is "Public" Don't ask. On my laptop the Public version was not allowed. Why it needed to be I don't know. I've only 1 printer connected albeit via WiFi. Anyway ticking both "Event manager" items in the firewall seems to have worked.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

See how VFX studio Rise created 'Jabariland', holograms & digital doubles in Marvel Studios' Black…

Best Android emulators for Mac

Comment importer des contacts d’un iPhone à un autre iPhone ?