Epson Stylus C60 Problem

  [DELETED] 11:47 21 Mar 2006

I have a red light showing permanently now on my printer and it refuses to operate. I have tried uninstalling it but keep coming up against the following dialogue..."Warning-The default printer has been deleted. The new default printer is EPSON Stylus C60 Series" There is then a box with the "O.K." to press. When I press that it tells me that the uninstall is complete. But it is still appearing in the "Add or Remove Programs Window" I was hoping to be able to just uninstall completely and then re-install from my disk. but no matter how many ways I try I am getting nowhere. If I had any hair I would have torn it out by now...The operating system is XP 2. Anybody suggest a cure? ..Bingalau..

  [DELETED] 11:55 21 Mar 2006

Have you tried unplugging the printer from the USB or parallel connection to your PC, then uninstall any relevant software from Add/remove Programs and also go to My Computer right click Properties>Device Manager and uninstall printer (it might be under USB printer support), re-boot. Then proceed to re-instal as per instructions that came with the printer

  [DELETED] 11:57 21 Mar 2006

PS go to click here , you may find some help

  [DELETED] 12:20 21 Mar 2006

terryf ..Thanks for reply and yes I have tried your suggestion already, more than once just in case I missed something out in the first couple of tries. I will have a good look through your site and its help sections. But I have been on that many troubleshooting sessions already and may have been on this one also. Anyway I will kep plugging away and if all else fails I will have to invest in a new printer. at least they are cheaper than the inks. The thing that puzzles me is that I can't seem to get rid of the bit in the Add/Remove program even after the printer is disconected from the computer altogether. That same notice just keeps repeating itself over and over, with no alternative to it. ..Bingalau..

  spuds 12:57 21 Mar 2006

Have you run a search in files etc, to see if part of the epson programmes is still present, and causing a re-install confliction problem!.

  [DELETED] 16:20 21 Mar 2006

I think that the red light generally signifies that the waste ink tank is full and halts the printer. The waste ink tank is a couple of sponges under the position that the cartridges rest in. They can be removed, washed, dried and refitted. But you will still need to reset the counter. You can download the Epson Service Utility from click here which will reset it, and the ink levels if you want as well. Might be cheaper than buying a new printer, although opening the case to get to the waste tanks can be awkward!


  Fruit Bat /\0/\ 17:19 21 Mar 2006

Epsons are all the same follow these steps to fix!

1) uninstall your epson printer making sure printer switched off.

2) Hold the windows key on your keyboard and click the Pause/Break button, the System properties dialog box will appear!

3) Select Hardware, Device Manager select the connection type either Universal Serial Bus (USB) or PORTS (COM & LPT) select your printers driver (epson...etc..)it will probably have a (!)by it click remove driver!

4) Restart your PC

5) Insert Epson CD into drive and load software when it says epson not found searching for connection then switch on your printer, Windows will detect it and use the driver off the cdrom to install it! Click next then Finish.

6) Restart your pc.

7) It is recommended you do a ink cartage nozzle clean on your printer once a month and print a test page! for more details consult your user guide / service manual

Problems with my Epson C40UX (60 is the same) printer, the red and green light began flashing and a window popped up, saying, take it to your services center because some parts have reached the end of their life.

Printer companies set a “protection counter” on all printers , it’s an internal counter measuring the amount of ink wasted by head cleaning.

Reset the "protection counter" as well as clean the “waste ink pad overflow”.

1. Unplug the power and USB cables from the printer. Pry open the C40UX printer, careful not to break anything. Use a flat blade screwdriver to pry it apart; there are two-three tabs at the back and two at the front. Gently push them in, and then using a bit of force pry apart the cover.

2. Next remove the two (2) waste ink pads. They are located at the back on the left hand side. I used the flat blade screwdriver to lift up the ink pads (they were soaked). Please use rubber gloves as it gets very messy.

3. Next wash them with just plain hot water until they are white again. I just let the hot water run on them (the pads are about three inches long).

4. Once washed dry them using a hair drier. (you could place it the sun for a few hours or on top of your heater or maybe in a heated oven; (make sure you do not set it on fire with too much heat).

5. Once dried place the pads back in the ink waste bin at the back of the printer.

6. Closed the printer cover and put back all the pieces and plug in the USB & power cable and turned it on. (Yes the lights are still flashing).

7. Go to this link and download this software: click here

8. Install the software and run it.

9. Select your printer and model number ( It only says C40 there is no UX, choose it anyway). It will ask if you replaced with new pads; say “YES”. Then close the window.

10. Now right click on the SSC service utility, it looks like a printer icon near your clock in the task bar.

11. Then click on reset counters. You can do all other stuff with this utility too.

12. Turn off the printer power and then turn it on again. If necessary un-plug the power cord from the back of the printer, wait 20 seconds. Plug it back in.


  [DELETED] 11:06 22 Mar 2006

Morning All!

  [DELETED] 11:11 22 Mar 2006

Morning All!
Managed to get the ink pads out and washed even if I did break one of the plastic clips in the process. Now waiting for them to dry on top of my radiator. If it all works out as it should then I will come back to update all you helpers and tick the "resolved" box, meanwhile wish me luck. ..Bingalau..

  [DELETED] 17:27 22 Mar 2006

Evening Folks!
Well I made a right pills of that, because I have damaged something inside the damn thing now. So I will tick as resolved and go and buy a new one...Unless I can find a repair shop in my vicinity.. Wonder how much they are now? Nevertheless, Thanks for your help. ..Bingalau..

  [DELETED] 20:41 22 Mar 2006

For my records

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Microsoft Surface Book 2 15in review

Illustrator Amy Grimes on how setting up her own eco-brand led to success with clients too

MacBook Pro keyboard issues and other problems

Test : l’enceinte connectée HomePod d’Apple