Epson R340 only recognised as composite device.

  [DELETED] 23:56 28 Jun 2006

Trying to install R340 on XP via USB2. The CD rom won't recognise the printer and when I turn it on windows pops up with USB2 MFP? composite device but can't install it because of no drivers.

Tried different USB ports front and back of the PC. Checked all leads.

Please help.

  [DELETED] 06:40 29 Jun 2006

Are you doing the install EXACTLY according to the instructions?

Printers, especially Epson printers, are extremely fussy about the way they are installed. If you deviate from that, the installation will fail.

I'm not certain about this particular model but most Epsons require the software to be installed before the printer ever goes near to being connected.

If, as you indicate, you don't have drivers get them from click here

  [DELETED] 07:26 29 Jun 2006

I have the CD that came with the printer. I run the setup and it tells me to connect and turn on the printer....

When I do, the set up doesn't find it and then xp throws up the found new hardware wizard for a USB composite device (instead of identifying it as the R340 which it should).

  [DELETED] 08:05 29 Jun 2006

I suggest that you remove all traces of the printer software from the machine (System Restore or restore from backup, if you can) and start afresh.

Ensure you are not installing via a hub.

  [DELETED] 08:24 29 Jun 2006

done that too.

I used destructive recovery feature to start the PC a fresh the other day it had been clogged up with all sorts so it was the easiest option. I have installed my usual hardware and software. The only thing different on the computer is the USB Sagem modem installed for tiscali.

I have emailed tech support hopefully I'll get a response soon.

  [DELETED] 08:26 29 Jun 2006

How odd!!!

  [DELETED] 08:30 29 Jun 2006

I really don't understand.

If I get a cable to connect it to the IEEE 1394 maybe that will help?

What a way to spend your day off. :(

  [DELETED] 08:40 29 Jun 2006

Is there a firewire connector?

  [DELETED] 14:17 29 Jun 2006

it mentions one in the manual. I'll check now.

  [DELETED] 17:35 29 Jun 2006

Email from Carl Ainsworth at Epson.

Took him just a few hours from my initial email and it's sorted...

Thanks to him and well done Epson for a speedy response.


It installs first as a usb composite device, then mass storage device and then as a printer and it was failing to find the generic drivers for the first 2 things.

I just had to insert my windows disk and point it to the I386 folder each time. Superb, once that happened the Epson installer recognised it correctly as the R340.


  [DELETED] 17:39 29 Jun 2006

As I wrote earlier:

How odd!!!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

How to watch the World Cup for free on TV and online

Adobe's brand-new video editing app Project Rush works across your computer, tablet and phone

Best external graphics cards (eGPUs) for Mac

Les meilleurs jeux pour Android (2018)