Epson R220 Printer Problem.

  Conny 00:02 26 Jul 2009

I have had my Epson R220 for about 2 years. Recently when I tried to print a document it came up with a warning box stating that certain parts in the printer needed to be serviced. With the cost of service repairs it will be much cheaper to buy a new printer so do you have any recommendations, needs to be a photo printer or is there something I could do to this printer to get it working again?
Thanks in advance.

  Technotiger 06:46 26 Jul 2009

Your printer is in the Supported list ... to download the program scroll to the bottom of the page ... click here

  Stuartli 09:33 26 Jul 2009

This will refer to the waste ink collection - Technotiger's suggestion will be of considerable value, but read the Help pages first..:-)

  Conny 22:07 26 Jul 2009

Hi Techno & Stuart. Have downloaded the prog but can't find any help files. When I click on the Resetter tab and click any of the boxes, i.e. 'Write', 'Check,' or 'Test' I get a message saying '[email protected] Device not found. I have also been told to remember to remove the 'chip'? What does this mean?

  woodchip 22:14 26 Jul 2009

did you choose correct printer from drop down list

  woodchip 22:16 26 Jul 2009

also check back of printer for a plate near cart end, this should give access to tube that is the wast pipe. if you get it going you could divert this to a external wast tank

  Conny 22:26 26 Jul 2009

Chose correct printer model, came up with R220/230. Will look for access plate and report back. Thanks guys.

  Technotiger 22:28 26 Jul 2009

If you right-click on the icon in your System Tray (bottom-right on your screen) you will then be able to click on Help!

  Conny 22:45 26 Jul 2009

Tried the help section but to be honest I am no techiee, got the plate off but can't see a tube just a little white blotter pad with some ink smears on it.

  woodchip 23:01 26 Jul 2009

If you poke about in there with power off with a bit of bent wire you should find a pipe

  Conny 23:28 26 Jul 2009

Found the pipe under the blotter but its as clean as a whistle except for a tiny bit of ink on the end, and I mean tiny. Lights on the top are still flashing alternatively so think I will just give up and buy a new printer. Thanks anyway guys for your trouble.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique