Epson Printer playing up.

  Baskerville 17:18 31 Aug 2008

Hi All,

I recently restored my comp back to factory settings and it all went well.
I had to re-install my Epson C62 printer with epson set-up cd, that all seemed to go well.
Someone in the family wanted to print off a document today and pressed print before noticing that the printer was actually turned off, not that this may mean much but after setting itself up the printer would not print the job, the document just goes into queue and the printer display 'communication error' on the screen, it does this whenever I try to print anything.
I decided to uninstall the software and tried to add the printer which appeared to go well, but again I just get the same error message, also when the print head or clean facility is used the print heads don't move, I have reinstalled the printer four times now and also got latest drivers from Epson but still no joy.
I'm using XP, and have changed USB port but still no joy
Thanks a lot,


  bobbybluenose 17:29 31 Aug 2008

try downloading the drivers again try thisclick here

  jack 17:38 31 Aug 2008

Though I would not have thought is necessary.
A simple switch off and switch on the printer may be sufficient and/or reboot the computer.
I have known the printer to carry on where it left off before a reboot.

  Fruit Bat /\0/\ 17:40 31 Aug 2008

Refresh USB Ports
Use Drive clean up to remove USB device drive info from the registry
click here
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  Green 1 01:36 01 Sep 2008

When I went from W98 to XP I had to use W2000 drivers for my C62 to work, hope this helps.

  Sapins 07:56 01 Sep 2008

This is from Epson.

Power off the printer and restart the computer. Leave the printer off, disconnect from computer. Reconnect the printer to the pc ensuring the printer is connected directly to that computer - NOT through another device such as a scanner or hub - this will affect the communication. Check both ends of the printer cable are fully secure at printer and computer. Access the printer queue and cancel any print jobs waiting on the computer. Power on the printer, access the printer’s properties and try a windows test page (from General tab).

If this doesn't help use the Live Chat on the Epson site, they are very good at sorting problems.

  Andsome 08:01 01 Sep 2008

I have always found Epson telephone support to be excellent. Try that.

  Baskerville 20:08 01 Sep 2008

Did what Fruit Bat said and used the drive clean, also took out USB in Device Manager, then used drive clean.
Started the computer but although found new hardware started it did not find any drivers, so I went to Epson and downloaded 2005 driver, re-booted and the printer was recognised and everything is fine now.
I think the problem was that some jobs were queued up and I could not get them off the queue and maybe this started a conflict?

Thanks everyone,


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?