Epson Printer offline and won't change

  Simmpy 18:13 17 Jul 2012

I have an Epson SX535WD wireless printer. Whatever I try to do it I can't get it to print as it constantly says printer offline. I am attempting to print from my desk top running Windows 7. I can however print from my iPhone or iPad using airprint?

  robin_x 18:44 17 Jul 2012

Try restarting the Print Spooler (even if running).

Start Search services.msc

That's the limit of my fault finding skills, I am afraid, if it still stuck.

  Woolwell 18:54 17 Jul 2012

How is your desktop connecting to the router? Assume SX535WD is wireless with all devices. I have this printer and haven't had any snags at all.

  Woolwell 18:59 17 Jul 2012

See Epson support online guides and follow all of the steps in turn. If you are unable to ping the printer or still get offline then come back.

Which Firewall are you using and have you ever been able to print from the desktop? Don't think the print spooler is relevant at the moment.

  Simmpy 17:51 18 Jul 2012

Thanks Woolwell Tried everything, Network status and connection and pinged it, all as should be? Alas printer still offline?

  Simmpy 17:53 18 Jul 2012

Sorry forgot to add, yes has worked with no problems until recently, using Norton

  Woolwell 18:11 18 Jul 2012

Can you think back to what changed? Perhaps a system restore to the point before it stopped working.

The only reason that I can think that it shows offline is that the pc doesn't recognise it being in the network or is blocked from doing so.

If you click on Start - Network does the printer show up? It should.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)