Epson Perfection 2480 scanner problems

  redeyenewby 16:21 07 Feb 2010

A few days ago I decided I would scan my 35mm slides and store them on fisk. The scanner was in an awkward position (underneath the printer) so, after I had scanned two slides I decided to move the scanner onto a nearby worktop for acceddability. Result the scan was of the whole slide support frame with two small rectangular white areas where the slides were. Since them I have uninstalled ans reinstalled my scanner, uninstalled and reinstalled my epson printer and scanner, emailed Epson 3 times (5 now) all to no avail. TheEpson techs were very prompt in answering, suggested checking my cable connections, scanned in Professional mode - still nothing. One peculiar thing occurred, when I shut down my computer with mains power still on I lifted the lid of my scanner and found that the light on the slide "sensor" had come on. When I tried to scan in Professional mode the film area stayed greyed out. The last two developments are the last items I have emailed to Epson today. Any ideas? I've tried downloading drivers, etc. from the Epson website to avail. Epson tell me that they don't have any driver downloads for the 2480 using XP. I bought the scanner December 2004 so it doesn't owe me anything but, IT WORKED PERFECTLY UNTIL I MOVED IT!!! Any ideas, please. Newby Stanley (redeyenewby)

  howard64 16:23 07 Feb 2010

you have removed the blanking plate from the top haven't you? Is it unlocked?

  redeyenewby 14:29 15 Feb 2010

Howard64, Yes and yes. I have now been to the local Epson registered repair shop and, in discussion with the repairman there we have ascertained that the (slide scan)light failure is affecting the slide scan setup (cannot set film as target, it remains grey in Professional). The scanner works fine as an A4 or photo scanner. I have been in touch with the epson helpline by phone and they refer me back to the repair shop. I feel sure that if I can replace the light source in the lid the scanner would be fully functional again.
Anybody!! Do you know where I can get a replacement light for the lid? It is a good scanner and if I can fix this light I'm sure I could load the scanner on my wife's PC. I just hate waste. Thank you all.

  jack 15:09 15 Feb 2010

The lid lightbox is connected to the base with a circular plug not disimilar to a Video/S or PS2.
Ensure it is correctly aligned and fully home.

  howard64 15:13 15 Feb 2010

The epson scanner I have has a couple of screws in the lid section I assume removing them will allow the lid to come apart revealing the lamp. Once you have access to the lamp you can then tell me what it is and I and others could help you find it.

  redeyenewby 17:48 15 Feb 2010

Howard64 and Jack, One of the first things I did was to examine the Din? type plug and even examined it under my magnifying glass. None of the pins appeared bent or damaged and the plug was firmly home. I took off the lamp assembly (all 5 screws needed to be removed to allow this). I have now bitten the bullet and opened the light fitting. Inside is a glass tube (L.E.D.?) approximately 2.5mm diameter and 19cm long. I am getting a gut feeling that, in fact, the problem is not the light - but I have no way of determining if it is or, if not, what it is. I'm open to suggestions. Thanks for your help so far. Keep it rolling. I might get an answer yet.

  redeyenewby 09:00 25 Feb 2010

Hi, Guys, Well - I spoke to the PC guy at PC World and he doesn't know what it is. He did, however, suggest that since I had lifted the scanner up AND TURNED IT OVER WITHOUT THE LOCK BEING ON that I may have caused some kind of contact to loosen, etc.. The main case body is held together with two screws but, after I took them out the top appeared to be difficult to remove. I'm loathe to force it in case I wreck the scanner completely but, I would really like to know what the answer to this problem is. Any ideas? Consider it a research project. Some good MUST come of it for others, anyway. Thanks again.

  woodchip 09:29 25 Feb 2010

look for other screws, may be under plastic feet little round pads. You have to pry these off

  redeyenewby 13:52 25 Feb 2010

Thanks, Woodchip-Of course -like externalFDD. Thank you.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Gmail : comment annuler l’envoi d’un e-mail ?