Epson Expression XP-750 Printer Waste Pad Full

  Peter~24 20:57 06 Nov 2016
Locked
Answered

Hello all, some help if you can please.

When trying to print on my Epson Expression Photo XP-750 printer recently I received the following error message :-

A printer's ink pad is nearing the end of its service life. Please contact Epson Support.

This is not really an economic solution as it will probably cost more to "fix" the ink pad and clear the error message than to replace the printer and I have quite a good supply of replacement cartridges that I don't want to waste.

I've tried the SSC Service Utility, but I could not find this printer on its list. I've also tried Mark Kneen's Epson PX700W Reset Program (Yes I know it's the wrong printer), but the virtual USB printer port isn't recognised.

The Epson website offers a ink pad full reset programme, but it can only be used once and I think I would like to use the printer a bit longer than one reset would allow.

Any suggestions so that I can use up my cartridge stock, before I have to replace my printer, would be appreciated.

Peter.

  lotvic 21:25 06 Nov 2016
Answer

You could try this free fix click here that I found via 'fixyourownprinter.com' you can watch the video to see how it works before you decide.

  Peter~24 12:46 07 Nov 2016

lotvic,

Thanks for the link. I started to download the video yesterday evening without realising that it was 3GB! in size. It took nearly an hour to complete the download so I will probably be viewing the video later today.

Sorry I took so long to reply, but for some reason I had a problem loging in. Possibly something to do with the recent site maintainance.

Thanks again for the link; any further ideas anyone?

Peter.

  lotvic 15:07 07 Nov 2016

Sorry 'bout that, 3GB, I hadn't realised, thought it would have been like a youtube vid. I'll go back to the site and have another looksee.

Login prob, yes will be because of the site maintenance stuff.

  Sapins 15:12 07 Nov 2016

ON my RX620 there is a tube accessed at the back which takes the excess ink to the pads, if yours has this tube hook it out and extend it to a smallish container, no more problems with full ink pads I can also reset the counter by holding down the Stop and Black buttons while powering on. I used these about 3 years ago, no problems afterwards.

  lotvic 15:22 07 Nov 2016

Sapins, brilliant info.

  Peter~24 23:06 07 Nov 2016

lotvic,

No need to apologise about the size of the video file; I should have notice before I started the download. The site offering help and the video download has a rather strange colour scheme and layout. I had to highlight some text to make it invert so that I could read it a bit easier.

Still haven't had a chance to watch the video yet; it is quite long apparently, but I'm not complaining if it will fix the problem.

Sapins,

Thanks for your input, but this printer doesn't have the sort of buttons you refer to. It has a small touch sensitive liquid crystal screen to operate different functions, but nothing I can see like you have suggested to press.

Peter.

  Sapins 08:44 08 Nov 2016

Peter~24 I think the info is buried somewhere, maybe a Google search will find it! Does the 24 have any connection with France?

  Peter~24 11:55 08 Nov 2016

Sapins,

Yes there probably is some information out on the web which a Google search may turn up, but so much of it is old and or misleading that I hoped I could save some time and effort by not reinventing the wheel and taking advice from someone who had already solved this problem.

As to the ~24 on the end of Peter, no there isn't a French connection. When I joined up to the PC Advisor web site, over 20 years ago, the user name Peter was available and I have been just plain Peter for many years, but yet another site reorganisation recently turned me into Peter~24.

Peter.

  Burn-it 13:42 08 Nov 2016

I got that messagefrom my epsom about three years ago. I took the pad out and washed and dried it, then used the reset tool. I haven't heard any more from it since and it is still in use. If I remember rightly the utility allows you to change the sensitivity of the test which (again memory) is TIME sensitive.

  Peter~24 01:04 09 Nov 2016

Thanks to everyone who contributed to this thread I eventually got to view the instruction video. I had to view it on my netbook because my old desktop wouldn't cope with the video and only played the sound.

Faffing about moving the 3GB video from the desktop to a USB stick and then to the netbook took quite a while, but it was worth it.

I followed the instructions, ran both programmes together and reset the waste counters to zero. Hopefully I won't see that error message again for a while and by then I might be on to a nice new printer.

Peter.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Windows Lite: what it is and when it might be released

Candid photography at home is helping Swedes to sell houses

New Apple Products 2019: Predicting the new Apple products coming soon

Comment installer Fortnite sur un Mac ?