Epson EPL5800 (Advanced) utilities tells lies!

  Diemmess 11:48 29 Nov 2006

Have had this laser printer for a few years.
Its print quality is excellent, its paper handling bearable!

Developed the habit a few months ago when asked to print, of showing a "Communication error...."

This seems meaningless, because whether I click OK or just ignore the message it carries on and prints.

This wouldn't really matter, but if I try Utilities and monitor, it balks with the same message and will not allow me to see how much toner etc is left.

I use Win 2000 and have tried every which way to uninstall/reinstall including total shutdowns and by-the-book the Epson CD.

Today after another attempt the Printers window shows it there as (copy 2) but no sign of copy 1!

I'm beginning to wonder if there is a line or two in the registry which is mucking things up?

  Pesala 09:58 30 Nov 2006

I have an Epson EPL5500 laser connected via USB. I find that it takes a minute or so to be detected. If you just switch on and start printing, then you get a problem. You can, of course, leave it switched on all day if you print regularly as the power down enery consumption is only about 5 watts.

Is the Epson Status Monitor loaded at starup? Have you tried using a parellel connection? Try switch the USB connection to direct from the PC instead of via a USB hub.

  Diemmess 10:57 30 Nov 2006

Thanks for your posting.
Yes the Epson Status monitor is loaded at startup (according to msconfig) but hides itself from me, except that "Search" says says a shortcut is in there.

Had a long 'live help' session with Epson yesterday, and the advice after asking the usual questions after that, was to follow the script of a long list of checks sent to me by email .

The difficult thing is that the printer still prints properly.
The persistant "Communication" error doesn't affect printing but prevents access to the Utilities.

  Diemmess 11:05 30 Nov 2006

Epson Printer Software in the Programs menu only offers help and readme files for the 870. The 5500 keeps its head down!

Very recently, and long after the error messages started, I installed an Epson scanner (Perfection V100.)

I'm sure as I can be this is not a cause of the problem.
It may make it more difficult to solve, because I have to trawl through all sorts of facilities for both the colour printer and the 'library' of stuff the scanner has added.

  Pesala 14:26 30 Nov 2006

Control Panel, Printers and Faxes, Properties, Utility, Monitoring Preferences. There is a checkbox there to disable the communication error. Mine is checked. Everything seems to be working as it should here. The model is the 5900L, not the 5500 which I had before this one.

BTW: I'm still using refill toner that I bought years ago for the 5500: click here

  Diemmess 15:59 30 Nov 2006

Two recent things.
1) Booting from a very plain (parallel) system which has Win2000, only basic drivers and this printer installed, there are no snags and all runs normally.

Have just tried another most careful removal and reinstall. The settings you quote in 'monitoring preferences' are exactly where I left them with the Coms. error not checked!
The default settings are not loaded!
This surely means that some corrupt or important registry line stays when I uninstall the printer?

  Diemmess 17:50 30 Nov 2006

Thank you for your input.
The EPL 5800 gives me a very good print, and is economical with toner.
What lets it down for multiple copies, is its make-shift cheese-pared paper transport, which will take any and every opportunity to jam once a run of copies is started and I turn my back!

This thread has about run its usefulness, I will start another on the best way out.

  Diemmess 16:58 01 Dec 2006

Thanks Pesala, for your sensible help.

Life is too short to make a big deal out of the problem.
W2K lacks the frills of XP and Vista but it still has enough back alleys to come up with strange faults.

In the end (using Hyperos) I built a new system from a clone of the the original simplest one in parallel and it is running very smoothly.

Some obscure error deep in the registry must have been the undiagnosed fault.

No ticks I'm afraid for this one.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

HomePod review

Streaming : Netflix ou Amazon Prime Video ?