Epson C60 Problem

  garby 09:37 22 Apr 2005

Need help with a printer. In the last couple of days my pc crashed, for what-ever reason the NTLDR file was deleted and, in the end had to do fresh Windows Installation. After all OS Software and application programs loaded and various bits from the back-up (true-image v8.0).
Pc did not recognize any USB connectivity at all. After various checks, re-loaded USB controllers, problem solved. Now, the printer was then recognized instantly...only problem was that there was about 20 sheets of paper loaded for use. All of it was loaded at once and fed through, making a lot of noise. Had to remove it manually, the problem i now have with the printer is that it will not load any paper at all. It acts normally trying to feed paper, mechanism turns ok, print head moves across waiting to complete process...only the paper is not being loaded at all. Ink has been changed, jet-tec ink loaded fine...shows ink is full. Any suggestions as to how i could resolve this problem or could it be expensive/terminal to fix.

  Giggle n' Bits 09:51 22 Apr 2005

then call epson. They have Epson Express service centres. if you go to click here then go to support look around for the express service centre in your area. if after 1 year old then I would just check to see no bits of excess paper are stuck in the rear paper feed or under the rollers.

  Pesala 10:05 22 Apr 2005

Probably cheaper to buy a new printer than to pay to have it fixed. I would be inclined to disassemble it carefully, and see if there is any paper blocking the feed mechanism. Might be wiser to ask Epson first if it is still covered by warranty. They're not that hard to take apart, but a bit of a jigsaw puzzle finding out where the plastic hook clips need to be released once you have removed all the screws.

  garby 13:05 22 Apr 2005

thanks for the replies guys, unfortunately it is still not printing. i looked for any stray bits of paper, but couldn't find any....also, i bought the printer in 2002 so i imagine the warranty has expired. I have contacted epson via their website for any ideas, but i won't hold my breath for a reply.....!!

If anybody else has any thoughts, i would entertain any ideas.

cheers Garby.

  Fruit Bat /\0/\ 15:18 22 Apr 2005

Go to this link and download this software: click here

Install the software and run it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?