Epson Aculaser Jammed!

  Pererin 10:29 22 Oct 2009

Hi Guys, me again. Problem with my Epson Aculaser CX21N, it jammed in (E) removed the jam but the error is still up on its screen. Turned it off and then on again but to no avail. I really need this up and running as I use it for work-tried the support on Epson, could not find anything to help me at all. Hope you can help as usual thanks in advanct to you for all your help in the past and future. :))

  jack 10:38 22 Oct 2009

Try remaking all the doors/hatches
Force feed paper/thin card into the track back and forth.

  jack 10:40 22 Oct 2009

I meant to say - manually force feed- push and pull that is .

  woodchip 10:46 22 Oct 2009

You need to check for bits of paper

  Pererin 17:04 22 Oct 2009

Hi Guys, firstly thanks for your speedy response, tried to force feed thin card through but as I am not sure where it goes at the back and it would not go from the front I did not continue. As for looking for bits of paper I found out that it was card and 2 or 3 sheets of it - which all came out through the back (E).

Cannot find Micro switch but have opened and closed the back door for (E) several times. Can not see where it connects to or what actually.Not really familiar with an Epson printer.

Is there a way to cancel the error message on the screen as I do not think there is any paper/card in the machine now, or do I have to try the Force feed again-if so is it where the rollers are in the back of the machine. Once again thankyou very much for your responses you are all a godsend - epson support had nothing on there that I could find and as I have always had a HP with excellent support and troubleshooting information I found this a bit lacking to say the least. ::))

  jack 17:23 22 Oct 2009

Examine the Eosin support site- for the E-mail direct question option for example
click here
also take as look at
The Epson forum
Also click here
Printer forum

  jack 17:25 22 Oct 2009

click here
The Epson forum

  Pererin 18:06 22 Oct 2009

Thanks Jack for all your replies-clicked onto the site you mentioned and managed to chat online to someone. They advised turning off and removing the power cable for a minute or so - going to try that asap and then the next tip which was to wipe roller on within the tray which I take to mean wipe the roller not sure it was not very clear and was not able to ask another question relating to it as I lost the page for some reason. Anyway thanks again for your help. :))))) big smile

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?