Epsom Stylus C70+ cartridge problem

  Housten 22:10 21 Nov 2012

Good evening,

I am hoping someone can help me!!

I have lost my manual so I can not refer to that. For the last 2 or 3 hours I have been swapping catridges with no effect, and I am now beginning to pull my hair out. What happened was I was just about to print a letter when it stopped. I had noticed a couple of days ago that I was running low on ink, but I thought there was enough for the two letters I had to print. On the top of the cover there are 3 lights, the left hand one tells you - or so I believe - that there is a fault. At the moment, it is either on or flashing, permanently.

I installed 4 new cartriges - which I got from Cartridge People, where the existing ones were from - and pushed them in. Not all clicked, but I need the letters, so I pushed on. No luck. I tried downloading manuals but got nowhere, although one told me how to change cartridges - not a lot of help. I can not get rid of this red light, where I have sometimes got the ink levels; what I have now is it showing all 4 inks sort of greyed out with a red circle with a white cross on the right hand one, but it had clicked into place. I have now tried 8 new cartridges and am getting nowhere, does anyone have any idea of what I have done wrong? Or is it that I have bought some duff cartridges?

Any help/suggestions/ideas will be very gratefully received.

Many thanks in anticipation.

  northumbria61 22:33 21 Nov 2012

You may need to RESET the Smart Chips - have a thorough read here and give it a try - enter link description here

  Housten 09:57 22 Nov 2012


Many thanks for your reply, which I will read shortly. The panic has now subsided, although for how long is debateable, as I had forgotten to switch it off last night - I have the computer and all the peropherals controlled by a 10-plug tower. So I switched it on this morning, and it came on AND it is working!!!! HOW??? WHY??? Not a clue, but I will be checking it and your suggestion out later this morning!!

Many, many thanks for your reply.

  BT 11:38 22 Nov 2012

....that is switch it off and on again...

That is what we always did in the days of the Spectrum. It usually cured the problem.

  northumbria61 17:23 22 Nov 2012

That is what we always did in the days of the Spectrum.

AND the Commodore 64 !!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S10 review

Butcher Billy's Black Mirror artwork is coming to vinyl for the first time

Is the Apple Store down? What's Apple launching?

Comment modifier le DPI d’une souris ?