Easy silver laptop wont start

  awest3 17:49 27 Nov 2014

Hi, I was asked to resurrect an old laptop, PB easy silver 2800, yes its that old, I reckon it dates from about 2000. A friend, I'll call him that loosely as I believe I'm in a no-win situation. Anyway the charging light does not come on when plugged in, the battery does not hold charge. However when it is plugged in (battery in place or not) and you hit the power button the light comes on for a second and I can hear the HDD start to spin..the light then goes off and its dead again. So what have I done so far.. tried to find a manual to no avail, checked the power brick, light is on and giving out 19.42v so I assume no problem with the power brick. I then stripped the laptop down to check the memory, oh dear! built in memory only (256Mb), there is a slot (took me ages to find) under the keyboard where another 256Mb could be fitted, empty). I then tried to find the HDD (10Gb) so I could test it on my Desktop ..that was fun! it's actually located, and attached to the floppy disk drive. I'd taken this out earlier when stripping it down and so was scratching my head a bit when I could find no evidence of a HDD. The HDD works perfectly and I could see all the system and data on it when it was attached to my PC. I whipped out the fan assembly which was hiding the Cpu, took the Cpu out. It looks ok visually so I added some grease between it and the heat sink and put it back. Whilst I was in there I replaced the CMOS battery. On reassembly it still does the same so no further forward. I checked as many of the connections, as I could by removing them and refitting. The laptop is worth about 10p so I may just buy him a cheap replacement.. I'm intrigued as to why it wont start though. I did actually see it working about 3 weeks ago ( it was so slow you could have written a letter and received a reply by the time it sent an email). Anyways up if anyone has any suggestions, other than throw it in the bin (which is where it's probably going) I'd be very grateful. Thanks Al

  awest3 17:58 27 Nov 2014

Sorry should have mentioned. The laptop is running XP SL3. There are no beeps.

  Fruit Bat /\0/\ 18:14 27 Nov 2014

Only worth messing with for the fun of it.

xp with only 256MB must be slow :0)

sounds like power supply part of the motherboard is overloading as drive guts in.

tried check power jack is secured, a warm of the solder my cure any dry joints causinhg high resistanc and hence the overload.

  awest3 20:52 27 Nov 2014

Ok thanks. I'll give it a go and let you know. Al

  awest3 15:58 03 Dec 2014

Ok.. so I took out the mother board, what fun!

The power socket is well held. I warmed up the joints around the power socket so to speak.... all to no avail, once put back together, and that's another joy...but still only 2 screws left over and given the amount I took out I consider that a success.

It still does exactly the same, so its now going in the bin...It was fun in a sadistic sort of way...

Thanks for your help. Al

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro (2019) review

Magical mystery tour - Artist colourfully customises bus to promote positive mental health

Apple Streaming Service Release Date & Apple TV Subscription Rumours

Quel est le meilleur iPad ?