DWL-G122 problem

  hzhzhz 21:07 17 Dec 2005

Ive set up the dlink 604 router with the ethernet cable.Its working fine. When I tried to install the G122 wireless adapter in another pc from the disc, it failed. It gave the message 1628 Failed to complete installation. So then I tried the same procedure with the pc with the router attatched and I got exactly the same message. I have 2 pc,s which I cant install the drivers. Any ideas please.

  mgmcc 08:59 18 Dec 2005

Try a search in Google for "1628 Failed to complete installation". A couple of answers suggest it can be due to a conflict between files you are installing and files already in the "temp" folder. Clean out your temporary files and folders to see if that helps.

  dagbladet 09:33 18 Dec 2005

Had this very problem myself last night with the same combo. Overcame it by jiggling around with the order in which I did things I.E. adapter out, drivers in, adapter in, re-load drivers etc. Not very scientific but someone will be along soon who knows what he/she is talking about.

  hzhzhz 13:17 18 Dec 2005

Cheers for replies. I'll have a clean out and a jiggle around this afternoon.

  Taff™ 13:18 18 Dec 2005

Only had this happen once and I`ve set up a few of these! Try this. Unplug the USB adapter from the cradle. Go to Add / Remove Programmes and remove the Adapter (AirPlus G).Reboot and check that the "ANIO Service" & "ANIWZCS2 Service" is also deleted. If not remove them too and reboot.

Now insert the install disc for the adapter and reload the drivers. Reboot. Now plug the USB adapter in. Wait for the computer to find new hardware, find new drivers etc. It may all work fine at this point but I sometimes have to do a reboot again at this point just to be sure. Do it anyway and the adapter should appear in the taskbar tray bottom right of the screen. Double click it and search for your router.

  hzhzhz 13:32 18 Dec 2005


  hzhzhz 13:52 18 Dec 2005

After deleting "ANIO Service" & "ANIWZCS2 Service" I seem to have installed the drivers but I have the tray icon and the desktop icon but the adapter has no lights on yet. When I click on the desktop icon I get Wireless connection properties. I need a little more help please.

  hzhzhz 13:53 18 Dec 2005

The tray icon says "not connected".

  hzhzhz 14:24 18 Dec 2005

Got it connected and working. Thanks all esp.Taff™
Thanks again.

  Taff™ 17:07 18 Dec 2005

Sorry - Missed your plea for further help! (But Obviously you worked it out for yourself) Store your settings under the "Profile Tab" and it will connect automatically on every boot of the computer.

Have you set up Security Encryption (WEP or WPA) and changed the default Router log In?

  hzhzhz 17:25 18 Dec 2005

Have you set up Security Encryption (WEP or WPA) and changed the default Router log In?

No not yet, but some easy to follow steps would be a great help. I'm trying to fit this in between writing xmas cards,cooking, etc etc etc.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Visual Trends 2018: This year’s must-know colour, design, branding & photography trends

iMac Pro review

Apple Music : comment obtenir 3 mois gratuits ?