DVD/CD rw not seen by vista

  foxman 16:09 23 Oct 2008

Hi - I have a Fujitsu Siemens Amilo Pa 1505, with Vista Home Premium, 2gb memory. It has suddenly been unable to see my DVD. It doesn't appear under 'My Computer' and it doesn't appear in the Device Manager - vanished. It does have power, as when you push in a disk you can hear it spinning.
I have trawled google for answers, I have tried system restore, I have tried the registry fix recommended in many places (deleting the upperfilter and lowerfilter). But to no effect. The only changes I can think I've made to the machine are the automatic updates - but I tried a restore point prior to those and still no drive.
I've tried the Fujitsu siemens website for reinstallation of drivers, but it just tells me none are required with vista.
Is it time to get the screwdriver out and check physical connections?
Yours in some considerable frustration,

  Fruit Bat /\0/\ 16:17 23 Oct 2008

No CD/DVD or CD-ROM access is missing error Code 19, Code 31, Code 32, Code 39, or Code 41
Try this if the optical drives are not appearing in My Computer or Device Manager.
(This is sometimes caused by the removal of Roxio or other writing software.)
click here
Download XP_CD-DVD-Fix.zip and save this file to your hard drive. Navigate to where you saved it and double click the file to extract the contents. Locate the EXE file you extracted and double click it. A confirmation dialog will appear when the script is done. You may need to reboot for the change to take effect.
This utility is only intended for Windows® XP, but also appears to work for Vista.
You may need Administrator level access to use this utility. If you do not have Administrator level access, the program will say it is finished, but will not have made any changes.

Run regedit and navigate to registry key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}.
Highlight it and in the right pane, find the Upperfilters and Lowerfilters values.
Highlight each one in turn, right click and delete them.
Close regedit and restart the computer.
If in doubt make a restore point before making changes.

click here

  foxman 17:45 23 Oct 2008

I tried the download fix and it appeared to work for a while. Unfortunately it has disappeared again after perhaps an hour of coming back online. I'm mystified.

Thankyou for the suggestion - but will have to try something else.

If anyone has anymore suggestions they will be greatly appreciated

  skidzy 18:43 23 Oct 2008

This is slowly becoming a common problem with Vista.

As Fruit Bat /\0/\ has pointed out,this is a common problem and normally rectified with the Doug Knox fix.However for some reason or other and i cannot pinpoint the problem as ive yet,i think it could be something like a virtual drive is on the system.

Do you have anything like Alcohol 120% or maybe other burning software installed ?

I would suggest an uninstallation of these and clean up with Ccleaner click here then reboot the computer and then run the Doug Knox fix.

Alternatively look in Disc Management to see if the drive is listed there.
Right click Computer and select Manage/Disc Management...if the cd/dvd drive appears,try changing the drive letter and path.
Reboot the computer is the drive listed in Computer ?

  foxman 15:22 24 Oct 2008

Hi there. I have uninstalled burning software, except I still have nero on the machine which was bundled with it. The Dougknox fix works temorarily. I tried the Ccleaner, which spotted loads of errors and fixed them, but still no joy. I tried the DougKnox fix to get the drive back - quickly changed the letter to X:, but shortly after it vanished completely again.
Really am stuck now! I can see from google searches this is becoming quite a common issue - I guess I should join the crowds and tell microsoft in the hope they'll tackle the problem?

  skidzy 17:05 24 Oct 2008

Yes this is becoming a common issue and i can only think that your registry is being changed.

It is possible you have a connection problem if the drive appears and disappears.Is this a new laptop ? if under warranty,get it checked out.

Something to try but no idea if it will work;

Start and type MSCONFIG and enter,agree to UAC prompts.
Select startup and untick any relevance to Nero,apply and ok.Exit MSCONFIG and reboot the computer.
Now run the DougKnox fix if the drive is not visible in computer.

Does the drive stay visible ?

Im banking on Nero is changing the registry entries on startup.
This is a sot in the dark and certainly worth trying.

  foxman 15:18 27 Oct 2008

Hi there - I tried the msconfig, but can't find anything relating to Nero. I might have already disabled it via spybot tools.
In the meantime I've sent a help request to Fujitsu siemens and will see if they have anything useful to suggest.

Will let all know!

  skidzy 15:55 27 Oct 2008

Though grasping at straws with this issue at the moment,i do have an idea;

A while back Ccleaner and Regscrub (registry cleaners) were having some effect on some systems Flashplayer.Now this was cured with updated versions.

What im getting at and is only a guess at this time,if you have run a registry cleaner such as those above or even Reg mechanic/regcure/Eusing/Regscrubxp or Vista etc this maybe the problem.

If you have indeed ran a reg cleaner,you would have been prompted to save the backup,if you have saved the backup....restore this and see how you get along.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?