DVD/CD rom drive not working

  wrg 17:24 13 Dec 2011

Evening all

I have a Sovy Vaio. For some reason when I put a cd/dvd in the drive it recognises something is in there but will not allow me to rip audio cd. The laptop is only a few months old. When I put a cd in it and then try to open it by right cliking cd drive in my computer it just hangs. If I eject it then it stops hanging. WM & ITunes will not rip it either.

Any ideas, I have tried looking on the sony website for help but its pants. Sony analysis software on the laptop does not identify a problem.

Any help would be much appreciated.



  Fruit Bat /\0/\ 17:44 13 Dec 2011

Go into Device Manager and uninstall the drive reboot the machine and let windows find new hardware and reinstall the drive.

see if it works then.

  wrg 18:20 13 Dec 2011

Hi Fruit Bat

Tried that but when system reboots it does not find new hardware. Tried it twice. I go back into device manager and the drive is listed. I tried to open an audio cd again, ITUNES popped up and asked to be default player so I said yes. The audio CD shows up and ITUNES asks to import but then it system hangs. When I eject the CD then normal and ITUNES gives error message. The drive seems to be able to read DVD ok. I can right click on the drive with a CD in it and it allows me open it

  Fruit Bat /\0/\ 18:31 13 Dec 2011

OK sounds more like a problem with Itunes have you tried ripping with Windows media player?

If that works OK then uninstall and reinstall Itunes (if you really want Itunes on your machine)

  wrg 18:40 13 Dec 2011

Same problem get message saying not responding. It gets to the point at which it is ready to rip but hangs. By the way I hate ITUNES but as far as I am aware it is the only thing you can use with the IPOD.

Thanks for your help

  Fruit Bat /\0/\ 18:44 13 Dec 2011

Run regedit and navigate to registry key

HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}.

Highlight it and in the right pane, find the Upperfilters and Lowerfilters values.

If they are there Highlight each one in turn, right click and delete them.

Close regedit and restart the computer. If in doubt make a restore point before making changes.

retry the CD ripping

  ICF 18:45 13 Dec 2011

Will It play DVD's & CD's

  Ibanez2010 18:46 13 Dec 2011

I wouldn't suggest messing around in the registry especially if you don't know what you're doing.

  wrg 19:32 13 Dec 2011

Hi all, it will play DVDs. WMP gives message no CD inserted please insert CD but it brings up the titles in the preview pane. I just click on track one and it starts. Windows Media Centre automatically recognises a DVD it also sees an audio CD just tried one. It shows the CD but when I try play it it just hangs if I tab out and then go back in to it I just get a black screen. It does start to play but thats it. The drive just keeps whirring away

  ICF 19:43 13 Dec 2011

Are you using windows 7 ?

  wrg 19:55 13 Dec 2011

ICF yes using Win 7. Fruit Bat just tried your suggestion. Itunes came up with error message about missing registry keys please reinstall Itunes(not done that yet) I just tries the CD but once again just hung when tried to import. WMP did not see the CD at all.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique