DVD writer not recognized by Nero

  dangerusone 22:55 03 Jul 2009

I have been using Nero 6.6 for the last couple of years with no problems,today for some reason it kept asking if I had *BurnRights*. I tried to alter them in the Control Panel as asked,rebooted and was asked the same question again and again.
I then uninstalled that version and put on Nero 7 OEM that came with a Liteon DVD Writer I bought.
This installs OK but when I want to burn a disc image I have made using WinAvi from Avi to Vob it doesn't show The Liteon Recorder as the destination,it shows destination as Image Recorder.
I never had any trouble with Nero 6 before but I haven't used it for about 6 weeks.
Have I set Nero 7 up wrong?

  DieSse 14:49 04 Jul 2009

You probably need a Nero update (go to their site) to recognise more devices.

OR you could run the free Ashampoo software, which I use in preference to Nero, and seems to have no issues with picking up newer devices.

click here

  dangerusone 15:03 04 Jul 2009


I've taken Nero off and tried running Ashampoo but I'm getting the message *No Compatible CD recorder*

I have tried playing a DVD in the DVD Recorder(F drive) and it plays OK.
Thanks for yur reply

  dangerusone 23:57 04 Jul 2009

I have been on Liteon site and downloaded the driver for my model,now my problem is where do I install them?

  gazzaho 01:12 05 Jul 2009

The first thing I would check is the upper and lower filters for the drive, read through this article click here sometimes the registry entries for these filters can be corrupted leaving the DVD drive inaccessible or unreadable. Programs like Nero or iTunes can't access the drive. I'm not saying that this is your problem but it might be worth checking.

  DjSprinks 03:55 05 Jul 2009

Sorry to say this but dont use nero..its crap i had simular probs with a lite on lightscribe drive! :/

  dangerusone 12:38 05 Jul 2009


I tried editing the registry as you described,there were no upper filters only lower which I deleted as the article advised,then rebooted.
On rebooting should the filters be automatically rerecognized as neither of them are there.
Is this a sign that the drive is kaput?
This is the second time in less than a year that this has happened to me.The last time it was a Samsung Lightscribe DVD-RW which I ended up having replaced with the Liteon which was recognized straight away on booting up.


I have removed Nero and replaced with Ashampoo 9 which I haven't had chance to use yet owing to my problem, but I like the look of its many features

  gazzaho 20:17 05 Jul 2009

The filters should be replaced when the computer reboots as far as I'm aware of, I myself used the supplied applet to do it automatically, from the fix it for me section on the MS help page, you could try that.

Also did you try uninstalling the drive from device manager and rebooting? On rebooting Windows will re-detect and install the drive. It could be that the drive is on it's way out, does it read CD/DVD disks without problems?

The fact that this has happened twice now may point to hardware problems. My own system, bought last year had a problem with Samsung SATA drives and the motherboard which is an ASUS Rampage Formula X48. Two drives failed within a week of each other, the suppliers of the system swapped the Samsung brand for a Pioneer drive and it worked fine, until I installed Vista SP2 which seemed to screw my drive filters up, I used the fix on the page I linked to you and everything is now working. Your problem may be different as I said but I thought it worth mentioning.

I have used Nero myself for a few years now (using Nero 7 at the moment) and have had no problems at all with it on Vista or XP. This may change however as they don't plan to support older versions of Nero on Win 7. If/when I decide to upgrade to the new OS I may change to different DVD authoring software. I'm going to try Nero 7 on Win 7 RC for a couple of weeks to see if problems arise.

  dangerusone 22:02 09 Jul 2009

I finally despaired and took it in to my friendly local computer shop who tried a new writer which also would not work.
No matter what he did it would not work,the upshot was he put my old Liteon back in and reformatted and put the Windows XP SP3 back on and everything is OK now.
I lost a few files but nothing of any consequence as I use 2 external hard drives to back things up.

Many thanks for trying to help it was much appreciated.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique