DVD RW Drive Tray Won't Open

  RegScriv 11:27 10 Oct 2014

I've started getting problems with opening my DVD-RW tray on my PC. Pressing the button to open it does not initially work. If I go into Windows Explorer & right click on the DVD-RW drive then select eject, it works. Once I've done that, it'll work on the eject button. I've tried updating the driver but Windows tells me the driver is up to date. Anyone help?

  Ian in Northampton 11:36 10 Oct 2014

It sounds like a mechanical issue, so drivers wouldn't help. The symptoms tell me that the eject button is wearing out. 'Forcing' an eject from Explorer probably frees up the button mechanism enough to get it working again. If using the button is important to the way you work, I'd suggest replacing it: they're dirt cheap.

  Fruit Bat /\0/\ 12:02 10 Oct 2014

Does sound like a mechanical problem with the button could be tray is slightly out of alignment.

a bit rough but often works - with tray out, give the tray a good tug, press the button to close the tray then repress and see if it will open again.

  RegScriv 13:52 10 Oct 2014

Thanks for the feedback. Once it's working it'll work for the duration of the session until the next time I start the pc again. I'll try the tug trick to see if it works.

  spuds 14:02 10 Oct 2014

I assume the dvd drive as a 'pinhole' option for ejection. Have you tried that, if so, what happens?.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro (2019) review

Magical mystery tour - Artist colourfully customises bus to promote positive mental health

Apple Streaming Service Release Date & Apple TV Subscription Rumours

Quel est le meilleur iPad ?