DVD ROM not working

  kissag 09:37 06 Aug 2005

Since installing MS XP sp2, the DVD ROM will not read any files, audio CD's or DVD's, it is accepted in device manager as working ok and driver ok. The seperate DVD writer is working OK though.

I have uninstalled the driver and reinstalled but stil no response, I have tried to find a suitable driver but unable to do so, the drive is only recognised as an ATAPI 12 x DVD ROM drive.

Any help would be appreciated.


  ACOLYTE 10:18 06 Aug 2005

The lazers may have broken if its not reading any cd/dvd at all,esspecially if its been used as the main drive for installing things as well as playing dvd's.It will still show as working in device manager even if the lazers have packed in.You said its only recognised as an ATAPI 12 x DVD ROM drive what should it be?

  kissag 14:03 06 Aug 2005

The drive has not been used very often as I use tha main DVD RW most of the time, the DVD ROM worked upto installing XP SP2.

The drive is listed as ATAPI 12 x DVD ROM I was not sure if ATAPI is its type or make.

  Fruit Bat /\0/\ 14:05 06 Aug 2005

Uninstall the IDE channel the DVD is on, then scan for new hardware and let XP reinstll the DVD ROM.

  silly old git 14:23 06 Aug 2005

silly old git here i was told it could be the lasers, i re booted PC.both my dvd and cd rewriters now work,could either sp2 or the software that came with the dvd i have roxio which i have not re loaded yet.

  kissag 14:34 06 Aug 2005

Uninstalled OK Fruit Bat, then XP found new hardware, installed this, still wont work.

Rebooted Silly old git, still no good, got Nero latest reloaded version, works fine with my DVD/CD RW.

Might replace the DVD ROM, for the amount it will cost, could be a good excuse to buy the latest 16 x DVD rw DL and use the old writer as the ROM.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

HomePod review

Streaming : Netflix ou Amazon Prime Video ?