DVD Rom Drive-Not Detected

  jaycup 13:28 16 Jan 2005

MY MSI DVD Rom Drive is no longer detected by the BIOS on Boot-Up. This has come about due to me trying to upgrade the Firmware of the drive to change it to Region1. The flash upgrade seemed to go ok (in Dos mode) but when I rebooted the Bios would not auto detect the drive and the boot up was halted pressing F4 got me out of the boot-up problem but the drive no longer appears in Device Manager and is consequently unavailable. I have tried everything I can think of to get things 'back to normal', including an update of the Bios, but to no avail. Currently I have disconnected the drive from the motherboard. Do I have to accept that the drive is a write-off or is there a solution to this problem. If anyone has had a similar experience then I would be glad to have their comments.

  howard60 13:38 16 Jan 2005

try removing the drive from control panel system and the shutdown - connect the drive and then see if it boots and finds the drive

  jaycup 14:53 16 Jan 2005

Don't know what you mean by 'Control Panel System' but it is not available in Device Manager and is therefore not on my Computer at the moment. I have already re-connected the drive to the Motherboard and re-booted (several times) hoping that the Bios would detect it but this has not worked. I have evn switched it to another IDE Channel and re-configured Master/Slave combination. My fear is that the flash-upgrade has damaged the drive and I am hoping that someone might have experienced this already and can advise me one way or another. Believe me I have tried all the obvious 'fixes'.

  SEASHANTY 16:18 16 Jan 2005

Probably time to buy a new DVD-ROM drive. There are many warnings on firmware upgrades going wrong and leaving you with a u/s unit. Perhaps its as well that these drives aren't expensive these days.

  howard60 19:26 18 Jan 2005

have you visited the makers site and looked at their faqs? if no help try contacting them and see if they offer any suggestions. Normally they are only too happy to try and help.

  taffhughes 19:40 18 Jan 2005

I had a similar problem, I even lost the icon for my DVD ROM from my computer. After talking to my computer supplier help desk they got me to open my base unit (unplugged from the mains) and check all the connections to my DVD drive. I found that the "ribbon" socket was slightly loose and clicked back into place. On reconnecting to the main and powering up the DVD Drive reappeared and has worked correctly ever since

  jaycup 13:56 19 Jan 2005

Thanks for all the suggestions but the problem is now clear. It seems that I inadvertently flashed the drive with the wrong firmware (slightly later model). I have now got the drive recognised at startup and also in Device Manager and My Computer but it does not function properly,e.g., the drawer does not open and close so it cannot be used. I now have the correct Firmware update which would put it back to where it started from but now it will not install and gives the error message that it cannot open the file. I suspect that the installed Firmware is giving out the signal that it is a different Drive to the one I am trying to install. It is not of course but one can understand the confusion. I could do with something that would delete the installed Firmware and then I could install the proper one. Sorry if tis sounds confusing.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

How Sketch and InVision have revolutionised our design workflow

The best tech gifts for Christmas 2017

Les meilleurs jeux de société (2017)