DVD player error?

  ACOLYTE 12:54 14 Jan 2005

I have a pioneer 107D DVD burner today i wonted to play a DVD so pops one in and then got a message that: D:/the short cut that this link relates to is no longer valid or has been moved,if on a network blah,blah,any way the upcome was i couldn't get the DVD player to recognize any disc's CD or DVD when i put a CD in get the same error,in my computer the DVD drive is listed till i put a CD/DVD in then its listed as invalid?,if i take the cd out it shows as a DVD/RW drive again.

  Fruit Bat /\0/\ 13:35 14 Jan 2005

1. Check in device manager if any problems (yellow exclamation marks)

2. Un install and re install IDE channels

3. Check IDE cable secure in Drive and at motherboard end.

4. No CD/DVD
Try this if the optical drives are not appearing in My Computer or Device Manager. This is sometimes caused by the removal of Roxio software. Run regedit and navigate to registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}. Highlight it and in the right pane, find the Upperfilters and Lowerfilters values. Highlight each one in turn, right click and delete them. Close regedit and restart the computer. If in doubt make a restore point before making changes.

  ACOLYTE 13:55 14 Jan 2005

No exclamation marks in device manager,never used Roxio,and the drives do show up in My computer CD/RW and DVD/RW on same ide channel and CD/RW works fine all cables as far as i can see are fitted ok.I restared pc and had a BSOD windows recovered from an error something to do with MS temp.xms file? after restart DVD worked again but after i changed DVDs it went back to how it was before,baffled me too,lol.

  Fruit Bat /\0/\ 14:06 14 Jan 2005

Re-enable DMA using the Registry Editor

Run REGEDIT. Go to the following key:


It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

Alternative Method—Uninstalling the Port
1. Uninstall the secondary IDE port
To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

Reboot to make the changes active and permanent.

After booting Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

2. Reactivate DMA
But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

On Windows NT and 2000 you now have to reboot a second time, but Windows XP applies the change instantly. Then you can go to the same place in Device Manager again and check whether the device is now actually using DMA mode. If so, all is well.

3. Driver is not intended for this platform
If you keep getting the following error message:

There is a problem installing this hardware.

IDE channel

An error occurred during the installation of the device. Driver is not intended for this platform.

then the way out is to rename C:\WINDOWS\system32\drivers\atapi.sys (or a similar path on your computer) to something like atapi.old.

If that's not possible, you can try it from the repair console (boot from the Windows install CD and select the repair console).

If Windows always automatically recreates atapi.sys, you can try renaming it in safe mode or from a command line window or you can try to rename or remove it in the driver cache as well.

Desensitize Your Computer's IDE Channels
There's a bit more to it. The following article offers a way to reduce the incidence of this problem, although it still doesn't solve it altogether.

IDE ATA and ATAPI Disks Use PIO Mode After Multiple Time-Out or CRC Errors Occur
click here

Do read this article because it contains a useful long-term workaround. But you have to go through the procedure described here to re-enable DMA first. Assuming you've done that, insert the ResetErrorCountersOnSuccess registry values mentioned in this article into both the primary and the secondary IDE port registry keys as described.

Unfortunately this is only a half solution, because when you enter an unreadable DVD, you will get 6 errors in a row, and the IDE channel will revert to PIO mode, but at least when you pull out the DVD in time and then insert a good one, the error counter will be reset and it will at least be a bit more difficult for Windows to hobble your IDE drive.

  ACOLYTE 16:00 14 Jan 2005

This is a lot of info to ingest so will get back to you about it,what i can tell you now is that whenever i put a dvd in the drive i get a system error on screen it doesnt reboot just the blue screen witch is odd because it is set to restart on system errors,it doesnt give a lot of info only stop code,and loads of numbers nothing i can work with to rectify it but what was a nusence is fast becoming a pain i cant even put a game/music cd in the drive without getting a system error.

  ACOLYTE 16:06 14 Jan 2005

1 more thing after i have restarted the pc after the system error if i leave the dvd/cd in the drive it works perfect on reboot,if i change it back to square 1.

  ACOLYTE 19:30 14 Jan 2005

I think this has somthing to do with the msspyware download because its the only new install i have done and i have uninstalled it and it hasnt happened since,but its early days.

  ACOLYTE 11:29 16 Jan 2005

Uninstalling the microsoft spyware app solved this.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)