DVD drive not recognised

  Mike_S100 19:48 12 Nov 2006


I've recently had a problem with my dvd-rw drive as it doesn't show up in 'my computer' anymore and in device manager it says windows successfully loaded the device driver but cannot find the hardware device. There is power to the unit and you can still open and close the draw.

I've tried another drive and this is doing exactly the same thing.

Any suggestions as to how I can resolve this will be gratefully received.



  skidzy 19:53 12 Nov 2006

Missing cd/dvd drives can normally be associated with the removal of Nero/roxio etc (burning software)

Restore Missing CD/Dvd Drives

Missing cd/dvd drive
If it is showing an error code, 10, 39, etc., delete the drive.

Then follow these directions for clearing the Upper/Lower Filters: (might want to print this out)

1. Click on Start --> Run --> and type in 'regedit' followed by the enter key
2. Expand the "HKEY_LOCAL_MACHINE" key (looks like a folder) by double clicking it (or
3. clicking the "+" next to it.)
4. Expand the "SYSTEM" Key
5. Expand the "CurrentControlSet" Key
6. Expand the "Control" Key
7. Expand the "Class" Key
8. Please look for a key containing the following string of letter and numbers:
9. High light this key by left clicking once on it
10. On the right hand side you are looking for "UpperFilters" and "LowerFilters" under the "Name" column, once you find these please delete them by right clicking on them and choosing "delete"
11. Please exit the registry by clicking on the "X" in the top right hand corner of the screen

Reboot your computer

  postie24 19:54 12 Nov 2006

Have you tried a restore to when it was working?

  Totally-braindead 19:54 12 Nov 2006

Have you tried replacing the ribbon cable and making sure it hasn't come loose? Have you gone into the BIOS and checked to see if its recognised there? And lastly what operating system do you use?

  Mike_S100 20:04 12 Nov 2006

Thanks for the quick responses.

I haven't tried a restore yet because I'm not sure when it was last working properly. I don't use the drive very often so could have been some time before I noticed it, but I can try putting it back as far as I can if I can't get it resolved any other way.

I've checked the cable to make sure it isn't loose but I haven't tried a different cable. I think I've got one around somewhere though so I could give that a try. I've gone into BIOS and it is recognised there. My operating system is XP home version 2002 and service pack 2.

It has an error code of 41 in device manager so I might give skidzy's suggestion a try.

  skidzy 20:10 12 Nov 2006


Code 41
Windows successfully loaded the device driver for this hardware but cannot find the hardware device. (Code 41)

Recommended resolution

A driver was loaded but Windows cannot find the device. This error occurs when Windows does not detect a non-Plug and Play device.

If the device was removed, uninstall the driver, install the device, and then click Scan for hardware changes to reinstall the driver. If the hardware was not removed, obtain a new or updated driver for the device.

If the device is a non-Plug and Play device, a newer version of the driver might be needed. To install non-Plug and Play devices, use the Add Hardware wizard. Click Performance and Maintenance on Control Panel, click System, and on the Hardware tab, click Add Hardware Wizard.

On the General Properties tab of the device, click Troubleshoot to start the Troubleshooting Wizard.

  Mike_S100 20:52 12 Nov 2006

Originally the drive was not removed, it just stopped working. I've now got my spare drive in and the original drive is not connected. I've just tried reinstalling the driver but that didn't make any difference, and when I try to update it, it says the wizard could not find a better match for your hardware than the software you currently have installed.

I've also tried to restore to an earlier point but I've tried several different restore points and it keeps saying it could not be restored.

  WhiteTruckMan 02:48 13 Nov 2006

a dos bootable floppy disk? if not, download one. I dont have any links handy right now, but just google it, you are bound to find something.

Boot to dos. dont forget to enable cdrom support as part of the boot. Dont worry how to do this, it should ask you. Once you have a dos prompt, chances are, the drive letter has been bumped down one to make room for something called a ramdrive, but again, it should tell you if this happens, and what the cd drive is.

Make the drive current, insert a cd then try taking a directory listing. If this works then its a windows fault. Repeat with a dvd disc.


  squillary 08:15 13 Nov 2006

I bought a couple of DVDRW drives the other month and had something similar where Nero wouldn't find the drives. Run the NeroInfo tool and look at the drivers. It may well say there's some problem with aspi.dll or wnaspi.dll

Do a search for either file name and you should locate updated versions to reinstall. If it's the same as me, that'll do it. Hopefully it is.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

Best Mac video editors

Idées cadeaux pour geeks et tech addicts