DSL G604T and DWL G122 wireless not working

  Hobbess 08:21 06 Apr 2005

Just got this wireless D-Link bundle pack following advice on this forum, had trouble understanding how to set-up security and thought I had it sorted but have since been having problems, here is a summary any help welcome:

DWL g122 wireless adaptor- I have this installed and it seems to be working fine although I can't get the D-link software utility to run, if I double-click on the icon on my desktop it opens up the wireless connection settings. The lights on this also don't work.

DSL G604T router modem - This also seemed to have worked fine as I was able to get the adsl connection setup easily through an ethernet connection. While trying to get everything working I tried to install new firmware. The router locked up after installing the first lot of FS files so I reset using the button at the back. When it restarted the appearance of the software had changed! It now looked like the Australian manuals, can I get the old UK version back? Managed to set up the adsl connection again though.

Over the last 24 hours:
Took ages to get the G122 installed as it kept coming up as unknown device, it now seems ok
Initially the wireless connection worked with no security
Figured out that I should use WPA with PSK and got that configured, seemed to work
Moved my PC away from the router it kept losing the connection
Tried firmware updates
Can now not get a wireless connection at all, secure or open, the adaptor can see the connection most the time, just not connect

Throughout this my PC can fairly easily find the wireless network with or without security but always fails to connect.

  JonnyTub 04:08 07 Apr 2005

This should help you figure some of it outclick here

  JonnyTub 04:12 07 Apr 2005

Upgrade procedure

WARNING: DO NOT upgrade the firmware over a wireless connection. Doing so could damage the DSL modem.

Your current settings will be lost after upgrading.

Step 1 Please visit click here and download the latest version of firmware. After the file downloads do not open it as it will not work.

Step 2 Open a web browser and type the IP address of the DSL modem in the address bar (default is Press Enter.

Step 3 The default username and password are admin (all lower case). Click OK.

Step 4 Click the Tools tab at the top and then click Firmware on the left side.

Step 5 Click Browse and navigate to the file you downloaded in step 1. Select the file by left-clicking it once and then click Open.

Step 6 Click Apply. It will take a few seconds for the upgrade to complete.

NOTE: Do not reboot the DSL modem during this procedure.

Step 7 After the router reboots, close your web browser and reopen it. Repeat steps 2-3 to login and access the Firmware page again.

The firmware version should reflect the new version. If the firmware version didn't change repeat steps 5 and 6.

If you have problems accessing the web-based configuration, unplug the power to the DSL modem, wait 10 seconds, and plug back in. Repeat steps 2 and 3.

If this doesn't work, perform a hard reset. To perform a hard reset, insert a paperclip and into the hole above the word RESET, for about 10 seconds and then release. Wait for the lights to stabilize (stop blinking) and then repeat steps 2 and 3.

  Hobbess 21:23 07 Apr 2005

Thanks, for the advice, had previously managed to get firmware installed and did it again just for kicks.

In the end had tried a bunch of things - new firmware, hard resets, open connection, PSK connection, MAC sharing, using windows to connect or the D-link software. None of it worked!

Have now resigned myself to returning and trying a different bundle pack.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

See iconic duo Smith and Foulkes' epic animation for the BBC's Winter Olympics coverage

iMac Pro review

Idées cadeaux pour geeks et tech addicts