Drives recognized by bios but can't boot OS

  twistercool 13:15 13 Sep 2018

Hello everyone. After trying to dual boot my system with windows 10 and ubuntu, and having several weird problems like not being able to choose on startup which OS should boot (grub not working), my computer started not being able to boot to windows at all (or linux on the hard drive), because my drives aren't recognized as bootable devices. Here are my systems specs: -Gigabyte Ab350m gaming 3 with F23d bios -R5 1600 -ddr4 8gb×1 corsair vengence lpx -gtx 980ti -3 drives: 120gb kingston ssdnow300, 2tb seagate barracuda and 1tb random 2.5"hard drive scavenged from my old laptop

I can load linux with my bootable usb stick, even though it's only the "try ubuntu" option. I can boot into the windows recovery environment with another bootable usb. I can open my bios. When I go to "Chipset", I can see that the bios recognizes my drives (APU SATA Port0: KINGSTON SV300 (120.0GB), APU SATA Port1: HGST HTS541010 (1000.2GB) and Chipset SATA Port3 is ST2000DM006-2D (2000.3GB)), but when is go to the Boot option priorities, I can see only my bootable usb sticks, the same options as in boot overdrive. Before, it would list all of my drives. I tested with another laptop drive I had laying around and it did recognize it in the BIOS, but wasn't bootable either (it has windows 10 on it). I did dick around with options I didn't understand well in cmd (I wanted to force ubuntu/grub to be booted before windows so I could actually use ubuntu), but the problem appeared randomly a few boots after the changes that didn't seem to affect my pc. I have tried some things, like formating my drives through the windows stick or trying to install it on an unused drive but it doesn't work, it shows me error messages. Ubuntu and the windows recovery environment do recognize the drives, and I can see the files in ubuntu. I would be very thankful if anyone could try to help me.

  Jollyjohn 15:43 13 Sep 2018

I think you have corrupted what I would refer to as the Master Boot Record (MBR) except yours is a modern motherboard that uses a UEFI BIOS. See here click here for an explanation of where Boot files are now stored. I suggest a fresh install of W10 especially as Quote "I have tried some things, like formating my drives through the windows stick or trying to install it on an unused drive but it doesn't work, it shows me error messages." You may need to create a new EFI partition.

Once W10 is installed and running, Google for a guide to adding Ubuntu and dual booting.

  twistercool 17:08 13 Sep 2018

Hi Jollyjohn! Thanks for the suggestion. I tried fixing the MBR on cmd (with the recovery usb stick) by inputing the command "Bootrec.exe /fixmbr", but it still doesn't let me boot with my sata drives.

  Fruit Bat /\0/\ 13:10 14 Sep 2018

Boot from the install disc (DVD or USB) - Click Repair your computer Choose Troubleshoot, then Command Prompt. Type these commands in the order shown below and press Enter after each command:

diskpart

sel disk 0

list vol

Select the volume number that has the FAT32 under the Fs column:

sel vol 2

where 2 is the number of the FAT32 partition printed by Command Prompt above.

Assign a unique letter to this partition. The letter must not be already available on your computer, e.g. C: or D: or E:

assign letter=r:

The confirmation message should appear: DiskPart successfully assigned the drive letter or mount point.

Type exit to quit the diskpart utility (step 4):

exit

Type the following command, but replace r: with the letter of the partition you chose earlier:

cd /d r:\EFI\Microsoft\Boot\

Type the bootrec command:

bootrec /fixboot

Backup your old BCD configuration to create a new one:

ren BCD BCD.Backup r: with the letter of the FAT32 partition mentioned earlier:

bcdboot c:\Windows /l en-us /s x: /f ALL

Remove the media from the drive: DVD or USB

Type exit

Hit Enter

Reboot the computer

  twistercool 13:24 14 Sep 2018

I finally resolved the main problem! (Although I still have other minor ones). I had to boot into the windows recovery environment and use cmd to convert my main drive to GPT. With that I could reinstall windows (after formatting it) and solve the other problems. Unfortunately, I lost all my data from my ssd, but I did think of making a backup before trying to dual boot linux. I certainly won't try to dual boot on the same drive for a long time haha.

  Jollyjohn 15:19 14 Sep 2018

Well done. If you want to try Linux, you could install VirtualBox and a virtual Linux PC to try. To Dual boot - Google Dual boot gpt drives w10 & linux - there are lots of results - this one is worth reading -click here

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

Huawei Mate 20 Pro review: In-depth hands-on

Adobe's groundbreaking prototypes of new features and apps for Creative Cloud

iPhone XR release date, price & specs

Test : le Samsung Galaxy A9