Drivers not loading

  charliep 09:08 30 Sep 2011

I have a Dell XPS Studio 8100 running Windows 7pro 64 bit. For some reason I can't load any drivers. I've ran diagnostics, tried Dell Support (useless), Whenever I try to load a driver I get an error message (28) telling me the driver is downloaded but won't load. I now find certain peripherals are acting up. For example this morning my Belinea monitor opened up displaying the wrong resolution,I went to the Display option on the Control Panel - just a generic monotor - no belinea,won't accept the driver. Just to emphasise, this is not just a particular driver but any driver won't load. Any suggestions welcom.

  rdave13 09:21 30 Sep 2011

Check your had drive for errors.

  charliep 11:57 30 Sep 2011

Thanks rdave13, ran a check for disk errors using the Dell Diagnostic Tool - no errors. Ran a check using AVG PC Tuneup - no errors. Ran a full anti virus scan using AVG, Malwarebytes & Spybot - no errors.

Downloaded a driver update tool called Driver Tool which tells me on one page my Geforce driver needs updating and on another page there are 20 errors. Of course it will only fix them if I register - I've not done so yet. I seem to remember downloading a similar driver tool which I installed then uninstalled without using their services. Could these tools cause a driver problem?

Regards, Charliep

  spuds 12:06 30 Sep 2011

"Could these tools cause a driver problem?"

Not necessary so, but it might pay to try downloads, which are usually free, straight from the component manufacturers website.

I could be well out of line, but it might be worth trying to download for free, Microsoft Fix-It and see if that helps?.

  Woolwell 12:13 30 Sep 2011

Have you done a system restore back to the time when the drivers worked?

  rdave13 12:26 30 Sep 2011

This is the site for your graphics card driver Nvidia

If you're sure the hdd is ok then try running the system file checker. Start- and in the search box type cmd . Right click it in the list and select run as administrator . Type sfc /scannow and let it run. Note the space between c and /. If it finds a problem and can't fix it then run sfc again. You might need to run it three times. If all OK then you could try this, MS fix-it

I'd get rid of Driver Tool, personally.

  charliep 13:09 30 Sep 2011

Thanks guys, will try your suggestions anf get back to you.


  charliep 11:34 05 Oct 2011

Tried all the suggestions but no joy - in fact its worst, can't get into windows at all now. Couldn't use my wireless mouse & keyboard so got new Microsoft usb mouse & keyboard. Everything seemed to go fine until it started to load the drivers for the new mouse & keyboard then a messasge "drivers failed to load" and now can't get past the user log in screen. Any further suggestions before I try the penultimate option - re load windows?


ps using my laptop for this.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)