Drivers for Matshita UJDA720 DVD/CDRW

  Al94 09:36 11 May 2005

Despite running AVG, Adaware, Spybot & Spywareblaster, I managed to get malware on my laptop which caused all sorts of problems. I had previously backed up my system using Backup on XP Pro to an external hard drive so last night decided to restore it. All is fine now with one major exception, no drivers for my DVD/CDRW which in control panel gives me the message "windows cannot initialise device drivers for this hardware code 37" I have tried uninstalling the device and rebooting - no change. A search on the web led me to find a driver (sorry doing this from memory as not at home this morning)which is a .sys file, when trying to update drivers it appears to be looking for a .inf file.

Help please.

  Gongoozler 10:12 11 May 2005

Try this one click here

  Al94 11:24 11 May 2005

Thanks -I'll try that one later when I'm home.

  Stuartli 15:27 11 May 2005

You shouldn't need anything other than the basic Windows CDROM driver - perhaps you are confusing the driver with firmware?

When you install a CD-ROM/CD-RW or DVD writer Windows normally installs the driver itself.

Have you checked the drive's Properties in Device Manager and that it is Enabled from the General tab menu?

  Al94 18:32 11 May 2005

Just home from work and have to cut the grass before I can spend more time on this! You're right Stuartli, it shouldn't be a problem, the drivers properties show the message quoted above and it is Enabled in the General tab menu. There is the dreaded yellow asterisk beside the device in the device manager menu. I have tried uninstalling and running new hardware wizard and/or reboot, shows that the drive is found but doesn't come up as installed. As the drive isn't working, I can't run the XP disc.

  Al94 18:34 11 May 2005

Gongoozler - had a quick look at your suggestion, clicking on the driver brings up a page saying that it has been removed from the database

  Fruit Bat /\0/\ 18:52 11 May 2005

Uninstall then reinstall the IDE channel the Drve is on

  Gongoozler 18:54 11 May 2005

Try putting the .sys file in the C: drive root. I might work, and it can't do any harm.

  Totally-braindead 19:16 11 May 2005

Only idea I have is go inside your PC and physically disconnect the CDRW drive by disconnecting the ribbon cable from the back of the drive, reboot and it'll then be deleted (as its no longer there). Switch off, reconnect the CDRW and restart and see if that helps.

  Al94 22:08 11 May 2005

Its a laptop so I don't want to take it apart! Not having any luck here at all, tried putting the downloaded .sys file in the windows sys32 driver file but it cant be seen when I try to update the driver. Any more suggestions please?

  Al94 23:11 11 May 2005

Sorted! Haven't got a clue how but in desperation found this link click here and downloaded the patch in the third post - rebooted and it worked!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)