Drive Letters

  morddwyd 09:23 28 May 2012

Utterly silly question I know, but my mind, and my search answers, are totally blank (bit of senile decay creeping in!).

Just got a new laptop and partitioned the hard disc

However, the drive letters do not show in Explorer, and I cannot for the lief of me remember how to switch them on (Win 7, 64 bit)

Help please!

  johndrew 09:37 28 May 2012

Have a look in Control Panel/Administrative Tools/Computer Management and see if the partitions are there and allocated. You can also change the identities as required.

  morddwyd 10:11 28 May 2012

The partitions are formed no problem, and occupied. The drive letters also show up in Properties.

I just want them to show in Explorer. The partitions are there, with the titles I gave them, but no letters.

  KRONOS the First 10:17 28 May 2012

This any use? Click here.

  lotvic 17:05 28 May 2012

It's ages since I did any partitioning but don't you have to format them before they show up with a drive letter in Explorer?

  KRONOS the First 17:29 28 May 2012


No I don't think you do, I am sure that the last time I did on someones laptop to enable him to dual boot, ah but there again installing an OS would have formatted the partition. I am going to reinstall Windows 7 on the wifes PC in the morning and I will partition the drive and see whether it is necessary to format or not.

In fact the more I come to think of it you may well be right.

  rdave13 17:53 28 May 2012

Try this, in search box type folder options and under the view tab scroll down to show drive letters and tick the box.

  morddwyd 21:15 28 May 2012


I looked there too, but not carefully enough obviously.

Thank you rdave13.

Problem solved.

Thanks for all other responses.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

See iconic duo Smith and Foulkes' epic animation for the BBC's Winter Olympics coverage

iMac Pro review

Idées cadeaux pour geeks et tech addicts