Dr Speedtouch

  gannite 14:04 05 Sep 2008

my modem is the Speedtouch 330, when i run Dr Speedtouch to obtain my line stats it say`s device not found.I have the latest drivers for my modem installed. Any help most apreciated

  skidzy 14:34 05 Sep 2008

For what its worth gannite,ive seen several Speedtouch 330's and i use to use them myself...and the Dr Speedtouch has never worked correctly.

When you select test connection (or similar) from memory i think it was a 3 or 4 step procedure...it would never complete.

Though i found the ST 330 very reliable,you cannot beat an ethernet connection and router.

  Condom 14:57 05 Sep 2008

I also use the 330 but have no problems now with what I suppose you mean to be the USB Diagnostics (PPP) tool. I did have some problems before because I installed an updated Driver which turns out was only for the French market and not the UK. The current UK driver is I believe version 301.0.012. If it works OK I wouldn't worry too much about the stats as the info is a bit suspect anyway.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Why this awful City of Los Angeles job ad for a graphic designer is actually brilliant

iMac Pro review

Les meilleures prises CPL (2018)