dos freezes

  User-3C6E3936-E75C-41F2-9BA20F882E5CB35B 21:02 08 Nov 2003

When I boot into dos the message "invalid file" scrolls continuously and I can't get any further. Windows 98 runs ok. Any advice?

  daba 23:05 08 Nov 2003

There will be a command in AUTOEXEC.BAT or CONFIG.SYS root directory of C:\ which is calling for a file which can't be found.

checkout these files with a word processor (Like NOTEPAD) and verify that all the files in them exist on your PC.

stop a line of either of the files from executing, by putting a REM statement at the front of the line (eg. REM mode con codepage prepare=((850) C:\WINDOWS\COMMAND\ega.cpi)

note that REM in config.sys produces an error (if i remember correctly), but it stops the command anyway.

another option is to find the boot-up option to "single-step" through the commands in AutoExec and Config, and see which produces the error. I think this is activated by hitting F8 during boot-up, but someone else may advise better

  keith-236785 08:58 09 Nov 2003

daba is correct, tapping F8 on start up should allow you to choose safe mode, step by step startup.

good luck

  seedie 09:48 09 Nov 2003

You could try formatting a floppy in W98 and putting a SYS on it and then booting from it.


I'll give your suggestions a try. It'll be a while before I get round to it. I'll keep you posted.
Seedie, How do I put a SYS onto a floppy? Yours thickly-Weebob.

  woodchip 22:05 09 Nov 2003

explorer right click floppy choose format then choose system files to load onto floppy and start with floppy disc to try it

I looked at autoexec.bat & config.sys and found the following:
Contents of Config.sys:

2 versions of Autoexec.bat:
1 C:\Autoexec.bat contains:
Bad command or file name
DOSKey already installed

2 C:|WINDOWS\autoexec.bat contains
C:|WINDOWS>lh c:|windows\
File not found

Also tried formatting floppy & putting SYS onto it but when I tried booting from it I got the A> prompt and didn't know what to do next.

  woodchip 16:54 12 Nov 2003

If you have been clicking on MS-Dos Prompt in Windows that is not DOS, it only emulates DOS in a Window, Is that what as been crashing, True dos is when you start with the Floppy with the System files on it.

I have been starting by shutting down windows and clicking restart in msdos mode. This only stopped working after I re-installed Windows 98.

Managed to get into Dos at last by following advice to press F8 then step by step start up. Many thanks to all.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Moto G6 Play Review: First Look

iPad 9.7in (2018) review

Test : les écouteurs Bluetooth Honor xSport AM61