Dlink wireless problems connecting please help

  puma22 19:17 15 Nov 2005

Hi, a long and convoluted problem but here goes.
I have a wireless d-link rounter with DWL-g122 wireless adaptor. thaks to everyone here for helping me set it up a few months ago. It all worked fine until my brother came to stay with his lap-top. He tried unsucessfully to set his laptop up to connect to my wirelss network. Now I'm not blaming him, but my connection has not worked well since!
The issue is:-
1The green D in the task bar tells me that the usb wireless adpter is linked to my router
2the tv icon tells me that it is trying to aquire the network address and that it is renewing the IP address.
3It never gets further than this and does not seem to be able to connect fully.
4When i vew the settings it says the up time is 49 hours plus. Im not sure that this is an issue, but the pc has definaltely been swithched off in this time!
5I have unistalled the software and reinstalled. Brilliant!! this worked and I got a connection. But only after i unticked use widnows to establih network connection.
6However, everytime i log off and another user logs on or i switch off the PC i get the same issue. The only way I can connect is to reinstall the driver.
Any suggestions would be greatly appreciated.

  Taff™ 10:04 16 Nov 2005

I would suggest that the first thing you do is unplug the router and reconnect after 5 minutes. This will reboot the router. Then boot your computer once the router has all three green lights on or flashing. Your problem is obviously aquiring a network address and this may fix it.

Then Double click the green D in the taskbar tray. This will open the D-Link User Interface. Click on Site Survey and your connection should be in the top pane "Available Network". You need to add it to the Profile Pane below and make sure it`s at the top of the list by highlighting it and using the arrows to the right to move it up the list. (Above default connection if it is listed)

If you have encryption you will need to put the key into the profile when you add it to the list.

You need to check if your brother had access to the router settings and if he changed any of them since the uptime is 49 hours would suggest that the router was rebooted then.

  puma22 10:37 16 Nov 2005

Hi, i am going out now, so will swithc all off and do as you suggest on my return and will post with the results.
Brother, hand on heart promised that he didnt change anything!
I have been in touch with Dlink and also followed some of the advice on Dogbreath1's subject string. However, the updated driver for the usb wirelss made it worse and i oculdnt get the green d or the software to appear at all. So went back to the original.
Also thought about updating the firmware but the one on the website appears to be an older version of the one that came on CD??? Thought it best to leave it alone.
Also found on the website a file called GPL Source Code release? will this help?
By the way, the router is a DSL-G604T
Many thanks for your help!

  puma22 13:34 16 Nov 2005

thanks for the adivce, mcuh appreciated. I did as you suggested, switched back on, booted pc and everytihing worked! I'm going to leave this thread open for a little while jsut in case.
Thanks for the help, again much appreciated!

  Taff™ 07:34 17 Nov 2005

Same as me - The update for the adapter messed everything up and the firmware update wouldn`t install anyway. D-Link said it wouldn`t help with connectivity problems anyway! Hey Ho!

  puma22 09:19 18 Nov 2005

Yep, turning of the router has definately worked so going to tick this as resolved.
Many thanks!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Inside the iMac Pro - Apple's most powerful Mac yet

iMac Pro release date, UK price & specs

Comment nettoyer Windows et optimiser son PC gratuitement ?