Dlink router not applying encryption

  danielgent 19:35 26 Jan 2010

Got a strange problem here with a Dlink DSL-G604T. I think the routers faulty as its behaving strangley but I just want to check its not something I'm doing wrong. The wifi settings were set to default, a generic name like "dslgt4_3" for the SSID (or something like that). When I tried to change the SSID name (via a PC with an ethernet cable). neither of the 2 laptops I had on picked up a network with the new name, they just kept detecting the old network. On the router setup page I'd type in the new name, then click apply. every other router I've configured its pretty much instant, on this router I waited for a couple of minutes and still it didnt change.

Did a factory reset (and then had to reconfigure the connection). I just left the SSID as the default, but when I enabled WEP or WPA on the router setup page and hit apply, the network remained unsecured! I think when I first saw the router (the owner had been messing around) the wifi network had WEP on, but I'm not 100% sure. normally you just click apply and the settings change! I'm going to buy a replacement router but just wondering if with Dlink routers theres something special i need to do.

!Also - when I hit apply to apply WEP or WPA to the network, theres a popup informing me that "privacy set to WEp/WPA. multiple SSIDs disabled". Does this mean anything?

much thanks,
Dan Gent

  hzhzhzhz 21:11 26 Jan 2010

Tools > System Commands > Save all settings.
When you have applied any changes.

  danielgent 00:20 27 Jan 2010

When I was configuring the ADSL settings on the router I was on the phone to Talk Talk and they had me change the MTU size until the connection worked. Then i only had to click the apply button.
Also, straight out the manual
"From the drop-down menu, select an Authentication Type: Open, Shared, or Both.
Select a key by clicking a radio button on the left, select an encryption level from the drop-down menu on the
right, then enter the proper-length key. (Key length is outlined at the bottom of the window.)
Click Apply."

Have you dealt with this exact router before?

  danielgent 00:23 27 Jan 2010

the manual refers to the button you so speak of by
"Any changes made to the Router’s configuration must be saved to non-volitile memory or they will be lost if the
Router is restarted or powered off. When you are finished making changes to the Router settings, follow the
instructions here to save the new settings."
It does not say they only take effect when saved! (its a pretty wierd way to do it though, surely the settings should just save straight away?)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?